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1. Introduction

In this workshop you will learn how to apply image analysis and processing techniques, using
the public domain software ImageJ and some additions (plugins) made by Montpellier RIO
Imaging and others. ImageJ has been written and is maintained by Wayne Rasband at the
National Institute of Mental Health, Bethesda, Maryland, USA.

Image] is the successor of the Macintosh software NIH Image written by Wayne Rasband.
Imagel is written in Java, which means that it can be run on any system for which a java
runtime environment (jre) exists. It can be run under Windows, Mac, Linux and other
systems. It can be run as a browser plugin, on a website or as a standalone application.
Because of the easy way in which ImageJ can be extended, using macros and plugins, a lot of
functionality is available today, especially in the fields of microscopy and biology.

2. Installing ImageJ and MRI Cell Image Analyzer

2.1 Installing ImageJ

The ImageJ homepage is http://imagej.nih.gov/ij/. Go to the download page and download the
appropriate version for your operating system. In this workshop we will only use winXP. For
windows there are two versions available:

* Imagel bundled with the java runtime environment

* Imagel without a java runtime environment
To use the last version, the java runtime environment must already be installed on your
computer. For this tutorial we download the first ImageJ bundle. Run the installer and follow
the instructions on the screen. The first time Imagel is started, a configuration file for your
installation will be created.
The installer will create a quick-start icon and a desktop icon. You can use these to start
ImagelJ. You can open images by dropping them onto the desktop icon.

2.2 Memory Settings

Java applications will only use the memory allocated to them. Under Edit>Options>Memory

& Threads... you can configure the memory available to ImageJ.
|

MaximUm mamary: ﬁ MB
Parallel threads for stacks: |2

IKeep rmultiple undo buffers

¥ Run garbage collector on status bar click

0K Cancel | Help

Hllustration 1: The memory and
threads settings of ImageJ

The maximum memory should be set to % of the available memory on your machine. To find
out how much memory your machine has, open the properties of My Computer and look for
the amount of available RAM.
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A dialog tells you that the change will be applied the next time you start ImageJ. The
configuration is stored in the file /mageJ.cfg in the ImagelJ folder. Should ImageJ not start
after you changed the memory settings, delete the file ImagelJ.cfg, restart ImageJ and set the
maximum memory to a lower value. A double-click on the lower part of the ImagelJ launcher
window displays the amount of used and available memory. You can use
Plugins> Utilities>Monitor Memory...to monitor the memory usage.

< Imagel !.m

File Edit Image Process Analyze Plugins Window Help
B o|c|o|<| &)+ |\ A& 2@ ofslur] § | 4 [&] |

Memory: 1213K of 750MB (<1%)

Hllustration 2: A double click on the window displays
memory information.
The number of parallel threads for stacks is by default set to the number of processors or
cores available in your system.

2.3 Upgrading ImageJ

To upgrade Imagel, start ImageJ and go to Help>Update ImageJ... Select the latest version
from the list. ImagelJ will be closed. Open it again and look at help>about ImageJ to see the
current version number.

Alternatively you can download the latest pre-release version of Imagel from
http://imagej.nih.gov/ij/upgrade/. Download the file ij.jar and replace the version in the
ImageJ home folder with the new version.

2.4 Installing loci-bioformats

ImagelJ can read a number of image formats like tiff (and tiff stacks), dicom, fits, pgm, jpeg,
bmp or gif images. It can not read other formats like ics or Ism by itself. If you want to work
with these file formats you need plugins that can handle them.

Loci bio-formats is a project that implements a library which can read many biological image
formats. “Bio-Formats is a standalone Java library for reading and writing life sciences image
file formats. It is capable of parsing both pixels and metadata for a large number of formats,
as well as writing to several formats.”. ImageJ can take advantage of the bioformats library.
You only have to download the file loci_tools.jar from http://www.loci.wisc.edu/bio-
formats/downloads and to put it into the plugins folder of your ImagelJ installation. ImageJ
will automatically use it when it can not open an image itself. The easiest way to install the
plugin is to drag the link to the jar file directly from the website onto the ImageJ launcher
window. This will download the plugin and ask you where under the plugins folder you want
to save it. In this case you can save it directly into the plugins folder.

2.5 Associating file types with ImageJ

To open images by double-clicking we have to associate the file type with the ImageJ
program. Download the zip-archive of example images from the mri website
http://www.mri.cnrs.fr/index.php?m=66 and unzip the archive.

Right-click on a tif-image, select “open with” and “choose the program” from the context
menu. On the dialog click the browse button and select /mageJ.exe from the ImageJ home
directory. Check the “always use this program to open files of this type” option and click ok
on the dialog. In the same way associate jpg-images with Imagel.
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If for each image you open a new Image] instance is started, go to the menu
Edit>Options>Misc... and select the “Run single instance listener” checkbox. Instead of
running a new ImagelJ for each image, all images will now be opened in the same Image
instance.

2.6 Installing the Montpellier RIO Imaging plugins

We are going to use some plugins from Montpellier RIO Imaging, for :

* The visual scripting plugin

* The toolbox plugin

* The slide show control plugin

* The lookup table plugin
These are available at http://www.mri.cnrs.fr/index.php?m=38. To find them you can go to
the homepage of Montpellier RIO Imaging: www.mri.cnrs.fr. Click Research and
development>MRI-R&D-Software>MRI Cell Image Analyzer. Follow the Download MRI_
Cell Image Analyzer link at the bottom of the page. Download the zip-archive mri-cia.zip. To
install it, it must be extracted in the ImageJ home folder.
The AutoRun macro in the file StartupMacros.txt in the macros folder is run each time Imagel
is started. We can use it to switch to the MRI tool set at startup. Open the file from
Plugins>Macros>Startup Macros.... Find the AutoRun macro. You might need to un-

comment it by removing the // characters. Add the line
call ("gui.CellImageAnalyzer.switchToMRIToolset");

Save the changed StartupMacros.txt file.

Any menu command that can be found in the ImagelJ launcher window can be used as an
argument to the run command and any static java method can be called using the cal/
command.

3. A quick tour

Before explaining the image analysis tools in ImageJ in more detail, we will make a quick
tour to get an overview of the most important tools. We will use the images you downloaded
in section 2.5. Open the image A4 dapi 1.tif. You can drag an image from your operating
system browser to the ImageJ window to open it. We will use this image as an example in the
whole chapter 3.

B

figure 3: The example image
for chapter 3.

Move the mouse-pointer over the image and watch the ImageJ window. The position of the
mouse-pointer and the intensity at that position are displayed in the lower part of the window.
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If it is difficult to see the mouse over the image, you have probably the crosshair cursor
activated. You can switch back to a pointer cursor in the menu Edit>Options>Misc....

; Imagel

File Edit Image Process Analze Plugins Window Help

e mfsnf p|4]8] | ||

A |

BEoz|o < Ala o]l 2|®

¥=199 v=70, value=167

figure 4: Position and intensity are displayed in the launcher
window.

3.1 The tool-buttons

Now look at the tool-buttons in the ImageJ window. The twelve tools upto the color picker
are basic tools that are always displayed. The remaining tools belong to a toolset that can be
changed using the rightmost button. Try this and than switch back to the startup macros
toolset. When you click on a tool button the button remains pressed and the corresponding
tool will be active until you press another tool-button. Notice that the name of the tool is
displayed when the mouse-pointer is over a tool-button.

3.1.1 The rectangular selection tool

Make sure that the rectangular selection tool is active. You can now make a rectangular
selection in the image by clicking at a point and dragging the mouse. While doing this the
width, the height and the aspect ratio of the selection are displayed. Once you release the
mouse button you made a selection on the image. You can still change its position by clicking
into it and dragging and its size by using the handles.

figure 5: A rectangular
selection.

3.1.2 Measuring and the ImageJ Results Table

Try to make a selection that contains exactly one nucleus. Then press the key m on the
keyboard. This is the shortcut for the measure command that can be found in the Analyze
menu. The Imagel] results table will be opened. The table contains the results of the
measurements. All measurements will be stored in this global table. In the File menu you
have the possibility to duplicate the table to keep measurements. From the Results menu you
can remove everything from the system table with the command Clear Results. The Set
Measurements command allows to define which properties will be measured. Note that the
change will only be active for future measurements, the corresponding columns for already
existing measurements will be filled with zero values.
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L Results

i~

File Edit Font
lArea |Mean |x [ by |~
8120 8408 264 297 26730 29961

1
2 13034 8597 43450 109 42836 11311
3 12420 70.76 9553 J08.50 552.01 305.08
4 399 J5.74 269.50 361.50 27023 360.87
] 143 1.76 58550 418.50 2841 418.34
w
4 >

figure 6: The ImageJ results table.

3.1.3 Selection brush and tool options

Behind tool-buttons that have a small, red triangle in the lower right corner, you can find a list
of tools by right-clicking on the button. Remove all selections from the image. You can do
this by clicking somewhere in the image while the rectangular selection tool is active or by
pressing shift a (a is the shortcut for select all, shift-a for select none from the menu Edit-
>Selection). Right-click on the elliptical-selection tool button and select the selection brush
tool. Click in the image and move the mouse, keeping the button down. You can paint a
selection onto the image. Once you released the button, you can add to the selection by
holding down the shifi key while painting. You can remove from a selection by holding down
the alt key. These two modifier keys work for all kinds of selections in ImageJ. Note that on
some systems you have to use ctr/+alt instead of alt, since the operating system is using the
first option itself.

. Selection Brush ()

v Enable Selection Brush:

Size; |10 pixels

Ol | Cancell

figure 7: The options of the
selection brush tool.

Tools can have options. You can access them by double-clicking on the tool button. Change
the size of the brush used by the selection brush tool.

3.1.4 Polygon and freehand-selection tools

Try the polygon and freehand-selection tools. Note that you do not have to close the
selections at the end. For the polygon selection you can finish the process by right clicking
and the selection will automatically be closed. The freehand selection will be closed as soon
as you release the mouse button.
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| 3.1.5 Line Selections

The line selection tools: straight line, segmented line and freehand line can be used to
measure length and angles with the horizontal x-axis. Use a right click to finish a segmented
line. The angle tool can be used to measure arbitrary angles. The line tools have the line width
as a parameter. If the line width is bigger than one, the selection is an area and all area
measurements can be applied.

3.1.6 Profile plots

You can use the line selection tools to create profile plots. First make a line selection across a
nucleus, then press the key & (the shortcut for Analyze->Plot profile). Note that, when the line
width is bigger than one, the profile will be averaged over the width.

If you want averaged line profiles of horizontal or vertical lines, you can use the rectangular
selection tool instead. If you want to use vertical lines you have to press alt-k instead of & in
this case.

L Plot of A4 dapi 1 (103%)

200

150

Gray Value
=
=

50

0 20 40 60 20 100 120
Distance (pixels)

i List I Save... | Copy... |

figure 8: A profile plot along a line crossing a nucleus.

A profile plot can be used to measure properties like, for example, the diameter of an object
by taking into account only intensity values above a baseline, that is visible in the plot. Note
that the plot is an image itself and that you can make selections on it and measure them.
Furthermore the plot-image has a spacial-calibration that corresponds to the values displayed
on the axis of the diagram. This allows to measure values corresponding to the image from
which the plot has been created, independent of the size of the selection that was used to
create it.

3.1.7 Arrow tool, annotations, roi-manager and overlays

Select the arrow tool from the straight line tool button. Double click to open the options
dialog and set magenta as foreground color. Click in the image and drag the mouse to create
an arrow. With the shift modifier key you can restrain the arrows to horizontal and vertical
ones.

If you want to have multiple arrows you can add them to the overlay by pressing the b key
(shortcut for Image>Overlay>Add Selection). You can use the fext tool to add an annotation
to an arrow. Use ctrl+alt+b to add it to the overlay as well.
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figure 9: A non-destructive
overlay of arrows and
annotations.

If you want to be able to modify objects in the overlay, you have to add them to the roi-
manager. Roi stands for region of interest and the roi-manager is the tool that allows to
manage multiple selections. Use Image->Overlay->To ROI Manager to add the objects in the
overlay to the roi-manager. Note that you find the roi-manager under Analyze->Tools. Make
sure that Show All and Edit Mode are selected. You can now select a selection object by
clicking on its number in the image or by selecting it in the list in the roi-manager. You can
modify the selected selection object and make the change permanent by pressing update on
the roi-manager. To create an rgb-snapshot of your image with overlay use the flatten
command from the roi-manager.

Note that overlay and roi-manager can be used with all kinds of selection, not only arrows and
text. Delete all overlays and all seletions in the roi-manager. Make some area selections on the
image and add each to the roi-manager. Make sure that no roi is selected and press the
measure button. Each selection will be measured independently.

3.1.8 Point Selections

You can use the point selection tools to manually count objects in an image. With the point
selection tool use shift to add points. You can delete points using alt. Note that the numbers of
the remaining points change accordingly. If you make an error and you loose your selection
you can get the last selection back using shift+e (the shortcut for Edit->Selection->Restore
Selection). You can add the selection to the roi-manager or measure it. The options allow to
directly add each point to the manager or to measure it while you are working. If you use the
multi-point selection tool, you do not have to use shift to add points, so you are less likely to
accidentally delete the selection. As before you can use flatten on the roi-manager to create an
image that permanently contains the point markers. Using the more button on the roi-manager
you can save and load selections, in case you need a break in the middle of counting.
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figure 10: Counting objects with the point selection tool.

3.1.9 The magic wand tool

Use the wand tool to select all nuclei, one after the other. Add them to the roi-manager and
measure them. To do this you either need to change the tolerance in the wand tool's options or
you need to set a threshold on the image. If a threshold is set on the image the wand tool
selects all connected pixel above the lower and below the upper threshold value. To define a
threshold value press shifi-¢ (the shortcut for Image->Adjust->Threshold) to open the
threshold tool. Select Dark background. If you select the Over/Under mode in the right
selection box, values below the lower threshold will be displayed in blue and values above the
upper threshold will be displayed in green. Adjust the lower threshold and select the nuclei
using the wand tool.
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L A4 dapi 1.tF
B50x515 pixels; 5-bit, 327K

Hlustration 11: A lower threshold is set and the nuclei have been selected
using the wand tool.

3.1.10 The particle analyzer

Instead of clicking on each object with the wand tool, you can let the particle analyzer do the
work. As before, define the lower threshold, then call Analyze Particles from the menu
Analyze. Make sure that only Add to Manager is selected in the Analyze Particles dialog.
Then click ok. You can exclude too small or too big objects by supplying a minimal and
maximal size in the Particle Analyzer dialog.

. Analyze Particles ]

Size (pixel™2y:
Circulatity; | 0.00-1.00
Show: | Mathing b
[~ Display Results [ Exclude on Edges
[~ Clear Results [ Include Holes

[~ Summarize [~ Record Starts
v add to Manager

Ok | Cancell
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3.1.11 Magnifying glass and scrolling

The magnifying glass tool allows to change the zoom of the image. A left click zooms in and
a right click zooms out. When the image is bigger than the window the position of the current
view is indicated in the upper left corner. The scrolling tool allows to move the image in the
window by clicking and dragging. The keyboard shortcuts for zooming are + and — and the
scrolling can be done by holding down space. Scrolling with the space key down allows to
scroll while another tool is active.

i A4 dapi 1.tif (400%)
B50xA14 pivels, B-hit, 327K

figure 12: The position of the current view in the
image is indicated.

3.1.12 Foreground and Background Color, Clear, Fill, Draw and Revert

The color picker allows to select the foreground color from an image. Select the tool and click
somewhere in the image. The foreground color will be changed. In the options of the color
picker the background and foreground colors can be swapped and the colors can be selected
from a palette. Note however that only gray-scale values will be used as long as the image is
not a color image. You can use Image>Type>RGB Color to convert the image into a color
image. The foreground color will be used by the commands Fill and Draw from the menu
Edit and the background color will be used by the commands Clear and Clear Outside. After
you have changed your image you can reload the original version from disk by pressing the r
key (shortcut for File->Revert).

3.1.13 Macros

Macros are small programs written either in the ImageJ macro language or in a scripting
language, that can be run by ImagelJ to automate image analysis tasks. Click on the dev menu
button on the Startup Macros toolset and select Macros. This will open a list of macros on the
Imagel website. Search the macro with the name DisplayTiffInfo.txt. Drag the link from the
web-page and drop it onto the ImageJ launcher window. This will open the macro in the
ImageJ macro editor. You can run it using the command Run Macro from the menu Macros
of the macro editor. This macro will display some information stored in the header of the
image.
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File Edit Font

Image description from 'Ad dapi 1 tif':
Exposure: 100 ms

Binning: 2 % 2

Region: 1300 x 1030, offset at (0, 0)
Acguired from Pl

Suptract: Off

Shading: Off

Digitizer: Fast

Intensifier Gain: 0

Bit Depth: 12-hit (5 MHz)

Trigger On: 0

Temperature: -10

-

8-Bit Copy of A4 dapi 1

1 |
figure 13: The macro displays
information from the header of
the image file.

>|4]

We will try another macro. The macro ROI Color Coder.ijm can mark objects with a color
according to the value of a given property, for example area or roundness. Open the macro by
dropping it on the ImageJ launcher window. To use the macro we need the selections of the
objects in the roi-manager and the corresponding measurements in the results table. Set the
threshold and use the Particle Analyzer and the measure command from the roi-manager to
achieve this, then run the macro.
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B50x515 pixels; B-hit, 327K i+ ColorCa = ||:|| XI
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0.71
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0.29
0.14
0.00

lllustration 15: The
color code for the
figure 14: The roundness of the objects is marked with a color-  roundness in the left
code. image.

3.1.14 Macro Recorder and batch processing

Imagine we want to measure some properties like size and form of the nuclei in our image,
but in many images, not only in one. We could run all the commands needed on each image,
one after the other to achieve this. But we can do better: We can record the commands needed
to analyze one image and create a macro from them.

Start the macro recorder under Plugins->Macros->Record. Under Analyze->Set
Measurements select the properties you want to measure. Now set the threshold and run the
particle analyzer. In the particle analyzer select display results only. Then run Analyze-
>Label to add labels to the image that indicate which objects have been found. Remove
unneeded commands from the macro recorder, then click create and close the recorder
window. You should now have a macro similar to the following:

run ("Set Measurements...", "area mean standard modal min centroid center

perimeter display redirect=None decimal=3");

setAutoThreshold ("Default dark");

run ("Analyze Particles...", "size=10-Infinity circularity=0.00-1.00

show=Nothing display");

run ("Label") ;

Open the first image from the folder /3-batch and run the macro. Press shift-o (the shortcut
for File->Open Next) to open the next image in the folder and run the macro again. Repeat
this until all images are analyzed.

Of course we can still do better. We do not have to load each image manually. Copy the text
of the macro, then open Process->Batch->Macro and paste it into the text part of the dialog.
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Select the input folder. Create a new folder and select it as result folder, then press the
process button. As a result you will get the measurements in the results table and the labeled
images in the results folder.

x

[nput... | |D:ImriIFnrmatinnlimagesﬁ 3 - hatchi

Output... | |Dilmri‘LFnrmatinnlimageslresl
Cutput Format: ITIFF vI

Add Macro Code:  [[Select fram lisf] ¥}

run{*Set Measurements..", "area mean standard modal min centraid center
perimeter display redirect=rMone decimal=3";

sethutaThreshald{"Default dark";

run{*Anakze Particles.. ", "size=10-Infinity circularity=0.00-1.00 show=Mathing
display");

run{"Lahel";

Testl Qpen... | Sawea. .. |

Frocess | Cancel |

figure 16. The ImageJ batch processor.

3.1.15 Plugins

Plugins are java modules that can be used to add functionality to ImageJ. A large number of
plugins concerning microscopy is available. Select Plugins from the Dev menu button. This
will open the plugins page on the ImageJ website in your browser. Look for the SIOX
(Simple Interactive Object Extraction) plugin and click on the link. This plugin will allow to
segment color images by giving examples of background and foreground areas. To install the
plugin drag the siox_.jar link from the webpage and drop it onto the ImagelJ launcher window.
A file-save dialog will pop-up. Use it to create a subfolder Segmentation of the folder plugins
and save the plugin into this subfolder. It will now be available in the Plugins menu in
Imagel.

Open one of the images from the 04 — plant (roboter) folder. Run the siox-plugin from the
plugins menu. Use a selection tool and select multiple foreground zones holding down the
shift key. Then switch to background and select multiple background zones. Press the
segment button. If you want you can create a mask for further processing.
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Hllustration 17: The SIOX Segmentation plugin.

3.1.15 Image stacks

Stacks can either represent volume data or time series. Open the example stack 7/ Head from
the Stk menu button. Note the slider below the image. You can use it to select the visible slice

of the stack.

| t1-head.tif

>l

F1M129, 384.00x354.00 mim (256x256), 16-hit; 1€

=10l x|

1 ol

figure 18: A stack of images in ImageJ
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The play and pause button next to the slider allow to start and stop the animation of the stack.
A right click on the same button opens the options-dialog for the animation. Try the
commands z project, 3d-project and make montage. Combine allows to combine to stacks one
next to the other or one above the other, while Concatenate allows to add the slices of one
stack at the end of another.

3.1.16 The ImagedJ 3D Viewer

Change the current tool-set to the Plugins tool-set. From the 3D menu button select ImageJ
3D Viewer. If you do not have java3D installed, you will be asked if ImageJ should install it
for you. If you get this question answer yes. You need to restart ImageJ. Open the 71 Head
again and start the mageJ 3D Viewer a second time. From the viewer window use the File-
>Add Content menu to add the head to the 3d scene. As long as the scrolling tool is selected
you can turn the 3d scene by dragging with the mouse. Make a freehand-selection that covers
a part of the head in the 3D-scene. Select the head-object from the select menu. Use Edit-

>Fill to remove a part of the image data. Reselect the scrolling tool and turn the head so that
you can see the area that you cut.

1=

File Edit Select Transformation Wiew Help

Hllustration 19: A 3d scene. Part of the data has been cut-
off with the fill command.
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4. Help, Documentation and Extensions

4.1 Help and Documentation

At the page http://imagej.nih.gov/ij/docs/ you can find help for the menu commands as well as
a link to the MBF ImageJ manual. The page can be accessed from within ImagelJ via the menu
Help>Documentation....

1.500

The ImageJ user guide written by Tiago A. Ferreira can be found under:
http://imagej.nih.gov/ij/docs/user-guide.pdf

Further information can be found at the ImageJ Documentation Wiki:
http://imagejdocu.tudor.lu/doku.php

The new imagejdev.org (http://imagejdev.org/) is supposed to become the new home of the
ImageJ community in the future.

The book “Digital Image Processing — An Algorithmic Introduction using Java” can be found
here: http://www.imagingbook.com/index.php?id=15

Wilhelm BURGER ¢ Mark J. BURGE

Digital Image Processing — An Algorithmic Introduction using Java

Textbook with 560 pages, 271 figures and 17 tables

© Springer 2008

ISBN: 978-1-84628-379-6

The McMaster Biophotonics Facility offers an ImageJ manual and a collection of plugins
under: http://www.macbiophotonics.ca/imagej/

You can find more detailed explanation of some image processing techniques in the hyperlink
image processing ressource (hipr) at:

http://homepages.inf.ed.ac.uk/rbf/HIPR2/index.htm

4.2 Plugins

New functions can be added to ImageJ by installing plugins. Plugins either add commands to
some menus or they can be run from the Plugins menu and its sub-menus once they have been
installed.

You can access the ImageJ plugin-site from the menu Help>Plugins.... If the plugin is
available as a .jar or a .class file, you can install it by dragging the link directly from your
web-browser onto the ImagelJ launcher window. This will cause ImageJ to download the
plugin. It then opens a dialog that lets you copy the plugin into the plugins folder or into one
of its sub-folders.

As an example we will install a plugin that draws random ovals into a new image. Use the
help menu to go to the plugin site. Scroll down to the category Graphics and click on the link
Random Ovals. Drag the link Random_Ovals.class onto the ImageJ launcher window. Select
the folder Graphics in the Save Plugin... dialog or create it if it doesn't exist. You can now
directly run the newly installed plugin from the Pl/ugins menu, using
Plugins>Graphics>Random Ovals.
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Hllustration 20: The
result of running the
« Random Ovals »
plugin.

Should the plugin come as a zip file, unzip it into a temporary folder. If the content consists of
Jar or .class files, you can drag them to the ImageJ launcher window in the same way to
install them. Otherwise follow the instructions on the web-site from which you downloaded
the plugin.

4.3 Macros

Macros are scripts in the ImageJ-macro language. A number of macros is available in the
folder macros in the ImageJ base-folder. You open them by dragging them onto the Imagel
launcher window or by using Plugins>Macros>Edit....

You can access the ImageJ macro site from the menu Help>Macros.

You can directly drag a link to a macro from the web-browser onto the ImageJ launcher
window. This will open the macro in the ImageJ macro editor, from which you can run the
macro using the menu Macros>Run Macro (or ctrl+r). Try to run the macro Mandelbrot.txt
this way.

Mandelbrot Set
200%200 pixels; 8-bit; BBK

Hlustration 21: The
result of running the
Mandelbrot.txt macro.

4.4 Tools

Tools are macros that add a tool button to ImagelJ's toolbar. Note that the name of the tool is
displayed in the status line, when you move the mouse over a tool-button. There is a
difference between action-tools and tools. Action-tools execute a single command. They do
not change the active tool. When you press the button of a tool, that is not an action tool, you
change the active tool. The active tool will usually do something when you click in an image.
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An example of a tool is the Rectangular Selection tool. An example of an action tool is the
Abort Macro or Plugin tool.

There can be multiple tools hidden behind one tool-button. If this is the case a small red arrow
is displayed on the button. A right-click on the button shows the list of tools and allows to
change the tool. Look for example at the second button from the left. This is the elliptical
selection tool. A right-click on the button gives access to the selection brush tool.

File Edit Image Frocess Analkze Plugins Window Help |
OlelalolrlslbnaAla]o2[®[m]w s [/][a]#] |[»
Elliptic: | Elliptical Selection Tool ht click to switch)
W selection Brush Tool

Hllustration 22: A right click allows to select between
different tools.

A tool or a group of tools (those that share the same button) can have options. The options can
be accessed by a double-click on the tool-button.

~ Selection Brus![O][x

¥ Enahle Selection Brush
Size: [15 pixels

Ot Cancel

Hlustration 23:
The options of
the selection
brush tool.

From the menu Help select Macros. On the web-page scroll down to the tools folder and enter
the folder. Search for RGBProfilesTool.txt and drag the link onto the Imagel toolbar. All tools
right of the color picker will disappear and there will be a new tool button for the rgb profiles
tool.

RGB Profiles — =] [=

0 20 40 60 80 100 120
distance

Illustration 24 An save..| Copy.. | %=81.6, v=148.5

rgb example Hllustration 25: The rgb profile along‘
image. the line in the image.

4.5 Update Macros and Tools

There is a tool available that automatically downloads and updates the macros and tools from
the ImagelJ website to your local machine. Go again to the macros part of the ImageJ website
for example by using the menu Help>Macros. Scroll down and enter the toolsets folder.
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Search for Luts Macros _and_Tools Updater.txt and drag the link onto the ImagelJ launcher
window. Click on the leftmost menu-button and select Macro, Tools and Toolsets Updater>.
Then answer the questions in the dialog.

& Macro & Tool Updater B &

The updater will ook for new awailable macros, tools and toolsets.

Choose the update method  Update by exploring the web repertories

Choose Updater Options

& - Check for macros, tools and toolsets updates {longer quend:

% - |gnore duplicates {mowved macros):

This option check for modifications, corrections ar improvements
for the Macros, Tool and Toolsets already installed onto wour
Image] wersion.

% - Make an installation repaort.

0K Cancel

New macros, tools and toolsets will be downloaded into the ImageJ/macros, the
ImageJ/macros/tools and the ImageJ/macros/toolsets folders. Existing macros, tools and
toolsets will be updated if a newer version is available on the website.

5. Display and image enhancements

5.1 What is a digital image

Before we start to work on images we should answer a simple question:

“What is a digital image?”.

There are different kinds of images, of course. Images can for example be two or three
dimensional and they can have one or more color channels.

In the simplest case a digital image is a two dimensional grid of width x height cells. Each cell
is a square with sides of length p. The squares are called pixels and p is called the pixel size.
To each pixel, an integer value between 0 and a maximum value is associated. These values
are interpreted as intensities. 0 usually means no intensity, yielding a black pixel. Higher
values usually mean lighter pixels and lower values mean darker pixels.

The word pixel is build from “pix element”. Pix is a common abbreviation for picture.

Open the image examplel. You can either double click the image or use File>open from the
ImageJ window. When an ImageJ] window is active you can use keyboard shortcuts to call
commands from the ImageJ menus. To get the open dialog, click on an ImageJ window and
press ‘0’.
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fex... /OGS

4448 pixels; 3-hit, 21

Hllustration 26: The first
example image.
Use the magnifying glass tool from the tool-box and click multiple times on the image to get
the maximum zoom. You can now see the individual pixels. If the zoomed image appears
blurred, deselect Interpolate Zoomed Images in the menu Edit>Options>Appearance.

Hllustration 27: With a higher zoom,
individual pixels can be
distinguished.

The coordinates and the intensity value of the pixel under the mouse pointer are displayed at
the bottom of the ImageJ window. You can use the right mouse button to zoom out again. To
scroll the image hold down space-bar, press the left mouse button and move the mouse.
Remark that the origin of the coordinate system is in the upper left corner of the image with
increasing coordinates from left to right and top to bottom.
Save the image as a text image to the desktop and open it with a text editor or drop it on the
ImageJ window. You see the image as a matrix of intensity values.
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i example1.txt E]@

File Edi Font Macros
0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 =
0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
[} 0 0 0 0 [} 0 0 0 0 [} 0 0 0 0 [} 0 0 0 0
0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
0 0 0 0 0 1 3 7 7 5 6 4 0 0 0 0 0 0 0 0
0 0 a [} 3 8 13 19 25 28 25 18 il 6 0 0 a a 0 0
0 0 0 4 11 22 3 45 56 62 a2 36 24 17 8 2 0 0 0 0
0 0 3 9 20 37 56 80 92 a0 75 65 49 35 20 8 0 0 0 0
[} 1 6 17 33 56 81 106 118 111 101 87 73 52 31 14 3 0 0 0
0 2 10 22 42 69 98 124 130 123 119 114 95 63 38 18 5 a 0 0
0 3 12 26 48 76 101 122 130 133 131 117 97 69 41 19 6 0 0 0
0 5 13 27 47 77 101 121 131 139 133 112 87 63 40 18 6 0 0 0
[} 3 13 24 45 68 92 115 125 128 117 @9 75 53 29 13 3 0 0 0
0 4 10 24 38 a7 76 99 107 107 94 76 62 40 19 6 1 0 0 0
0 2 8 17 28 45 65 75 &0 81 67 56 40 21 9 1 0 0 0 0
] 0 3 12 20 31 42 51 52 48 42 32 21 7 2 ] 0 0 0 0
0 0 2 6 12 16 22 24 25 23 16 12 5 [} 0 0 a a 0 0
0 0 0 0 3 [ 9 9 8 [ 3 0 0 0 0 0 0 0 0 0
0 0 0 0 0 1 1 1 1 0 0 0 0 0 0 0 0 0 0 0
[} 0 0 0 0 [} 0 0 0 0 [} 0 0 0 0 [} 0 0 0 0
0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0=
0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
0 0 a [} 0 0 0 a [} 0 0 a a [} 0 0 a a 0 0
0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
0 0 0 0 0 0 0 0 2 4 2 2 0 0 0 0 0 0 0 0
[} 0 0 0 0 2 3 7 10 12 13 14 11 5 1 [} 0 0 0 0
0 0 a 1 1 7 14 17 25 30 30 29 26 16 7 2 a a 0 0
0 0 0 4 8 18 26 37 48 52 52 53 41 30 18 ] 3 0 0 0
0 0 3 8 19 29 44 60 72 76 73 67 61 45 30 19 7 0 0 0
[} 0 5 14 27 45 61 79 94 102 a8 88 70 59 43 26 13 5 0 0
0 1 7 18 35 56 79 99 111 114 108 94 80 67 53 36 19 8 0 0
0 4 12 23 40 62 87 105 123 124 111 a7 83 73 59 45 28 12 2 0
] 4 12 23 41 62 89 108 120 117 103 96 88 75 63 47 29 13 2 0
0 3 10 21 37 &4 80 102 108 103 96 88 80 &7 56 41 21 6 0 0
0 2 8 17 28 44 62 75 84 88 87 80 62 53 43 27 " 3 0 0
0 0 4 12 19 31 43 52 63 65 67 56 49 41 28 15 5 0 0 0
[} 0 1 6 9 16 25 34 39 45 40 38 32 25 15 5 0 0 0 0
0 0 0 1 4 8 13 18 22 20 22 18 16 8 3 1 0 0 0 0
0 0 0 0 1 2 4 5 9 6 T 5 3 0 0 0 0 0 0 0
0 0 0 0 0 0 0 1 0 1 1 0 0 0 0 0 0 0 0 0
0 0 a [} 0 0 0 a [} 0 0 a a [} 0 0 a a 0 0
0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
[} 0 0 0 0 [} 0 0 0 0 [} 0 0 0 0 [} 0 0 0 0w

4 I »

Hllustration 28: The image as a matrix of intensity values.

5.2 Brightness and Contrast adjustment

Open the image bc-adjust.tif. The image is dark and the contrast is very low. Open the
Brightness and Contrast Adjuster from the menu Image>Adjust>Brightness/Contrast or press
Shift+C or run the B/C-Adjuster from the Lookup Tables tool set.
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! be-adjust.tif (- OB
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190224 pixels; 8-hit; 42K

Hlustration 29: The
intensities are to low to
distinguish details in the

L

] 255 2 27
Al i [ |
Minimum Minimum
[ e 2 |
Maximum Maxirmum
A I i [ i
Brightness Brightness
[ I [ 2l i3
Contrast Contrast

192%224 nixels; 8-hit, 421

Reset

Apply

Hlustration 30:

Hllustration 31: The
image after the auto-
adjustment.

[

Reset
Apply

Hlustration 32:

image. After the

adjustment
intensities below 3
will be displayed
as black and
intensities above
26 as the 255.

The brightness and
contrast adjuster.

Press the Auto button to make an automatic adjustment. With Resef you can go back to the
original display. Use the four sliders to adjust brightness and contrast manually. Remark that
only the displayed intensities are changed, the pixel values remain unchanged.

Press the measure button on the toolbox or select the image and press Ctr/+m, then change
the brightness/contrast and measure again. Compare the values mean and IntDen, which give
the average and total intensity in the image. If you can’t find mean or IntDen in the results
table, open the dialog Analyze>Set Measurements... and check Mean Gray Value and
Integrated Density.

£ Results =Jo&d
File Edit Font

|Area |Mean |Min |Ma}{ |IntDen =
1 43008 9296 2 a1 399804
2 43008 9296 2 a1 399804 —

-

1| [+]

Hllustration 33: The ImageJ results
table.

How does the adjustment work? When the image is displayed two points are stored together
with the image. The point (min, 0) and the point (max, maxintensity). All intensity values
below min are displayed with the intensity zero, all intensity values above max will be
displayed with the intensity value maxintensity. Values between min and max are mapped by
the line equation that is defined by the two points (min,0) and (max, maxIntensity).
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In the beginning when we opened the example image, min was 0 and max was 255 and the
maxIntensity is 255. Since this defines a line with the gradient 1, each intensity value is
mapped to itself. After we applied the auto adjustment, min becomes 2 and max 27, so pixels
that have the intensity 27 are displayed with the value 255, pixels that have the intensity 20
with the value 184, and so on.

Now look at the image in the upper part of the B&C window. What you see there is the
histogram of the image. On the x-axis are the intensity values from 0 to 255. On the y-axis
you find the count of pixels in the image that have the intensity x. We’ll come back to the
histogram later when we talk about thresholding. For the brightness and contrast adjustment it
shows you how many pixels you set to the max intensity and to zero. On the left you find the
min display value and on the right the max display value. The line that is drawn in the
histogram shows the mapping of the values between min and max.

If you move the brightness slider to the right the whole line will move to the left and lower
intensity values will be mapped to higher display values, making the display brighter.

If you move the contrast slider to the right the gradient of the line increases so the intensity
values closer together will be mapped to display values with a bigger distance.

You can use the set button to enter the min and max value directly. If you press apply, the
pixel intensity values in the image will be changed to the values displayed.

The auto adjustment will look at the histogram of the image and adjust the min and max
values in a way that a small percentage of the pixels become zero and maxiIntensity.
Sometimes this doesn’t yield the desired results, especially when the object is very small
compared to the background. In this case you can make a selection on the image and the auto
adjuster will use the histogram of the selection to compute the min and max values that are
then applied to the whole image.

Use the rectangular selection tool from the toolbox to make a selection on the image and press
the auto button. Try this for different regions in the image.

4 wae =] E3

Kl D]
Level: 15

. 1]
Window: 20

Auto Reset

Set |  Apply

Another way to adjust the display is the Windowd&Level adjuster. In this case you choose a
middle value (the level) and a range around the middle value (the window). If you choose for
example /level 15 and window 24 you get a min value of 3 and a max of 27.

5.3 Non linear display-adjustments

In the brightness and contrast adjustments in the last chapter, intensity values are mapped to
display values by a linear function, meaning small intensities are changed by the same factor
as big values. In cases where very high and very low intensities should become visible a non-
linear display adjustment is needed, so that small values can become bigger without saturating
already big values.
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_ CFP-2.1if (33.3%) !E X|

650)(515 pl)(ElS a-hit;, 327K

BA0x515 pixels; B-hit; 327K

Hlustration 34: The low Illustratlon 35 A linear

intenSitieS are anlSlble ln dlsplay ad]usl’menl‘ makes
the original image. low intensities visible but
saturates high intensities.

5.3.1 Gamma correction
Instead of a linear function we will map intensities to display values using a function of the
form I’?r:mf = I’Er';.

128)(64 pixels; 32-hit; 32k 128x64 pixels; 32-hit;, 32k
A

Hlustration 36:  Illustration 37:
gamma = 0.4 gamma = 2.5

Open the image cells.tif or cells2.tif. Use Process>Math>Gamma to adjust the image
intensities using a gamma-function. You can select the Preview checkbox and try different
values. When you click ok the gamma function is applied to the image, i.e. the pixel values
are modified accordingly.

Walue (0. 1-5.0% (0.4
Ok, Cancel

lllustration 38: The Illustratlon 39: The gamma-

dialog for applyi{?g a correction has been applied
gamma-correctlon. to the image.

The exact function used by this command is:
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lo (17)
flil=e = 25255

This command in the menu Math is there to modify the pixel values of the image not to make
a display adjustment.

To adjust the display without affecting the pixel values the macro “GammaCorrectionTool”
can be used. ImageJ provides a convenient way to run macros and plugins from a toolset.

We will install the tool on a new toolset, so that it can be run by pressing a tool button. Look
at the rightmost button on the ImagelJ launcher window. Clicking on it allows to change the
current tool-set.

Image)

File Edit Image Process Analyze Plugins i owe Help ‘

= I
D|Q‘Q|@|/v‘4|+|ﬁ\|A‘O\IﬁD|7|V| |E‘£|ﬁ|m|“h‘ _|5tartup Macros
Switch to alternate macra tonl sets _|stack Tools

» MRl Tools

| Lookup Tahles
_| Drawing Toals
__|Tracing
__|Example Icons

_|Toolset Creator

_ MR Metrology
__|Plugins

_zd

__IMantpellier Rio Imaging
__|scale Bar Toaols for Microscopes
_|Region Growing
__|Arrow Labelling Tools
__|Magic Montage

_| Counting

__IHelp...

Lllustration 40: The button >> on the ImageJ launcher
displays the list of available toolsets

-

First we need to get the macro from the ImageJ website. Use Help>Dev. Resources... to open
the developer resources page on the Imagel website. Click on Macro Tools. Scroll down to
GammaCorrectionTool.txt and click on the link. You should now see the macro code in your
web-browser (Don't worry you don't need to understand the code, at least not right now).
Select the macro text (ctrl+a) and copy it into the system clipboard (ctrl+c). Now go back to
ImageJ. From the toolset list (click on the rightmost button to get it) select Toolset Creator.

Toolset Creator...

Taoolset name fwithaut extension) ‘Displa\x,&djustments

Containing how many toolsy (1-7) |1
Cancel

lllustration 41: Creating a new
toolset.

Enter Display Adjustments as the name of the new toolset and enter 1 as the number of tools.
The Toolset Creator is normally there to create toolsets from the plugins in the plugins menu.
We will just use it to create a new toolset and we will overwrite the created content. Normally
you would now enter information for each tool on the toolset. You can ignore this and press
ok. Close the log window. We will now open the code of the newly created toolset. Hold
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down the shift-key, display the toolset-list and select Display Adjustments. The code of the
toolset is now displayed in a text window. Replace the content with the content of the macro.
To do so click in the text window, press ctrl+a to select all and ctrl+v to paste the code of the
macro that we copied into the clipboard before. Save the changed file using the File menu
from the text window (or ctrl+s).

To update the display, reselect the Display Adjustments toolset again. You should see a button
with the Greek letter gamma. Open the image cells.tif or cells2.tif again or use File>Revert to
reload it. Now select the gamma-correction tool by pressing the button with the letter gamma
and click in the image. The gamma function is displayed on the image and you can change the
value of gamma by moving the mouse. When you have found a good value use ctrl+shift+a to
get rid of the function display in the image. Be careful to not click into the image again,
before you selected another tool. In contrast to the command above this macro only changes
the display, not the pixel values.

r cells.tif (G) (33.3%)
1300%1030 pixels; 8-bit; 1.3MB

lllustration 42: The gamma
function is displayed on the
image.

You might have noticed that using the same gamma value with the Processing>Math>Gamma
command and with the GammaCorrectionTool macro yields different results. This is because
the later uses a different gamma function:

f(i)z(%)§-255

5.3.2 Enhance Contrast

The enhance contrast tool, that can be found under Process>Enhance Contrast, has three
different functions. When neither Normalize nor Equalize is selected, the display is adjusted
in a way, that the given number of pixels becomes saturated. In this case the intensity values
in the image are not changed.

When Normalize is selected, a contrast stretching or normalization is done.

The third function is the histogram equalization.
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 Enhance Contrast
Saturated Pixels: 1.0 %

¥ Mormalize

oK Cancel

Hlustration 43: The
enhance contrast
dialog.

5.3.2.1 Normalization or contrast stretching

The normalization stretches the range of intensity values, so that the given percentage of
pixels becomes saturated. After a normalization the min and max values for the given image
type will be present in the image. If for example the minimum and maximum value in an
image are 10 and 20 the values can be mapped to use the whole range between 0 and 255 by:

i' = (i-image_min / (image _max — image _min)) * range _max
i'(10) = (10-10) / (20-10) * 255 =0

i'20) = (20-10) / (20-10) * 255 = 255

i'(15) = (15-10) / (20-10) *255 = 127.5

However this would be very sensible to outliers. A better way is to determine image min' and
image max' so that a given percentage of pixels is below image min' and above image max'.

" Histogram of crp-... [Ij[=] B

[ [
0 285 0 285

Count 334750 Min: 1 Count 334750 Min: 0
Mean: 36.73 Max 255 Mean: 87 .55 Max 255
StdDev: 3525 Mode: 26 (674949) StdDev: 59 34 Maode: O (126490)

; Value: 154 [ Value: 92
List | Copy | Log |

Count: 129 Count: 0

Hllustration 44.: Histogram Illustration 45: Histogram after
before normalization. normalization.
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 CFP-2.1if (G) (50%0)
Ba0xa145 pixels; B-hit; 327K

F g w

normalization.

Using the enhance contrast tool with the normalize option has the same effect as using it
without the normalize option and then pressing apply on the brightness and contrast adjuster.

5.3.2.2 Histogram Equalization

In the histogram equalization each intensity value i is replaced with the the sum of the
histogram values for all intensities up to i (including 4(i) itself). The result is then normalized
to the min and max intensities of the image type. If you check equalize histogram in the
enhance contrast dialog, the other input in the dialog is ignored. If you hold down alt, the
classical histogram equalization will be executed. Otherwise a modified version, using the
square root of the histogram values will be used. If a selection exists on the image, the
calculation will be based on the histogram of the selection only.
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Ta94 28 pixels; 8-hit; 317K

Cowtt I24E52
Waian: B1 46
S Dav 33 ET

1.

un-;

hlw! SDIBHDSI

List | Copy | Log |

Hllustration 47: The input image.

Value: 1

Count: 4

Hllustration 48: The histogram
of the input image.

Count 324852
en: 1010
D ARG

Nn:D

M 255
Wode: 33 (BT

List| Cop].r| Log |

Illustratzon 49 The image after

Value:

Count:

histogram equalization in the
square root version.

Hllustration 50: The histogram
of the image after histogram

equalization in the square root
version.

_ Histogram of hst-3 ... !E

]

L Caunt 324852
. a7
.“-. e ] aen: 127,54

NN D

M 258
Mrde: 48 [BIGH]

. ﬂﬂ" SHDer TR
b
) '?\.; p&‘

w‘nﬂ_ﬂﬂhﬂ

List | Copy | Log |

Illustration 51: The image after

Value: €

Count: £

histogram equalization in the
standard version (alt key down).

Hlustration 52: The histogram
of the image after histogram

equalization in the standard
version (alt key down).

Histogram equalization augments the local contrast and is most useful when objects and
background contain high and low intensities, as for example in brightfield microscopy.
Compare the results of a linear adjustment a gamma adjustment and the histogram

equalization on the image cells2.tif.
Try the histogram equalization on the image roots.tif.
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5.4 Changing the palettes

We will now change the display of our image by mapping the intensity values to colors. This
is done by the use of lookup tables. A lookup table is a table that maps the 255 intensity
values to 255 arbitrary colors. Since colors are expressed by the proportion of the three basic

colors red, green and blue, an entry that would map the intensity 255 to white would for
example be:

255 -> 255, 255, 255

To map the intensity 0 to red the lookup-table entry would be:

0->255,0,0

Select the Lookup Tables tool set. Click on the LUT button and open the Rainbow RGB lut.
You see an image that shows the mapping of the intensity values to the colors. Each intensity
value is represented by a column with the width of 1 pixel, painted in the corresponding color.
Can you tell in which color the intensity value 200 is displayed?

£ Rainbow RGB.lut =J2/Ed

2AE032 pixels; B-hit; 8K

Hllustration 53: A graphical
representation of the lookup-
table.

Go to the menu image>color>show lut. Above the color table you see how each color of the
lut is mixed from the red, green and blue components.

¢ Look-Up Table =Jo&d

326x188 pixels; RGE; 236K

285

| I
0 254

List...

Hlustration 54: The red, green and blue
components for each index of the lookup-
table.

If you click on the list button, you get the lookup-table in numerical form. What are the RGB-
components of the intensity 100?
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LT =JoEs
File Edit Font

Index [Red [Green [Blue | =
98 10 239 20

99 10 244 15 m
100 10 243 10

101 12 247 10 .
. I

Hllustration 55: Part of the
lookup-table.

Open the image cells and click on Rainbow RGB lut again. When images are opened the
lookup-table will be applied to the active image. Try different lookup tables.

=%

B[]

1 cells.tif (25%)
13001 030 pixels; &-bif, 1.3

1 cells.tif (25%)
1300x1030 pixels; 8-bit; 1.3ME

i cells.tif (16.7%
1300x1 030 piels, &b

3MBE]@

Hlustration 56: The Hlustration 57: The

Hlustration 58: The 3-

rainbow RQB lookup- grey lookup—‘table 3-2 RGB lookup table
table applied to an applied to an image. lied .
image. applied to an image.

The lookup table HilLo is useful to adjust the display of our image. 0 will be displayed in blue,
255 in red and values in between will be displayed in gray. Can you describe how this lookup
table looks like?

! C:\Documents and Se... [ [0S

28632 pivels,; 8-hit; 8K

B

Hllustration 59: The hilo lookup-
table.

Apply it to the image and adjust the brightness and contrast in a way that most of the
background is zero and only a small portion of pixels becomes saturated.
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¢ cells.tif (25%) =1} © cells.tif (33.3%)

13001030 pixels, 8-hit, 1.3MB

031030 pivels; 8-bit, 1 3ME

Lllustration 60: Use the Lllustration 61: The
hilo lut to adjust brightness and contrast
brightness and contrast. adjustment has been
applied and the lut has
been changed back to
grays.

Go to image>color>edit>lut or press the Edit LUT button from the Lookup Tables tool set.
Change the lookup table in a way that 0 will be displayed in green, 255 in yellow and values
between 100 and 120 in different shades of red, becoming lighter with higher intensity. Save
the lookup table under a new name, apply it to the image and adjust the B&C again.

+ LUT Editor

1 cells.tif (33.3%) M| =1] ]

1300x1030 pixels, 8-bit; 1. 3MB

Cancel Hllustration 63: The newly
created lut applied to an image.

Hllustration 62: The lut editor.
Open the MRILookupTableTool under Plugins>Montpellier RIO Imaging. The tool allows

you to see the lookup tables and to apply them either to the active image or to all open
images. Remark that the external lookup tables listed in the tool must be in the folder [ut.

volker.baecker@mri.cnrs.fr 35/93



mailto:volker.baecker@mri.cnrs.fr

Image processing and analysis with ImageJ and MRI Cell Image Analyzer

[ Lookup Tables [Z]@
0 red ) green ) blue

) cyan ) magenta 1 yellow

) gray @ fire ice

i spectrum 0 3-3-2rgh i red f green
) other | imert | | invertal
hrown |~
cornflower 1
cyan hot I
cyan pale |

green fire hlue
green fire hlue2
green fire
green hot

oroor rod weollonss

| set all | | standard

|_set |

¢ fire M=%

286x32 pixels; 8-hit; 8K

Hllustration 64: The MRI look-up
table tool.

Another convenient way to access all lookup tables is to tear off the Image>Lookup Tables
menu by using Plugins>Utilities>Control Panel.

A Show Parent

[ coal sl
D Cyan Hot

[ edges

[ gem

D Green Fire Blue
[ HiLo

yica

[ 1caz

[ 1cA3 |
[ Magenta Hat =

lllustration 65: Menus
can be kept on the
screen using the Control
Panel.

5.5 Overlay of multiple channels

A common task in fluorescent microscopy is to create a combined image from the different
channels. The task consists in creating an overlay of the different channels, in adjusting the
display of each channel and eventually in transferring the settings from one overlay to
another, to allow a visual comparison. In ImageJ this can be accomplished using so called
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hyperstacks. Hyperstacks allow to work with multidimensional images. The different
dimensions are the X,y and z axis, the time and the channel (representing the color or
wavelength).

Open the images dapi 3.tif and rhod 3.tif from the folder /7 — overlay.

i RER| REE

Ba0x515 pikels; 8-hit, 327K Balxa14 pixels; 8-hit, 327K

lllustration 66: The first channel contains  Illustration 67: The second channel
the dapi staining. contains the rhodamine staining.

Run the Merge Channels... command from the menu /mage>Color.

¢ x|

Red: [rhod 36if_~ |
Green: m
Blue: lm
Gray. [*Mone* - |

W Create Composite

[ Keep Source Images

i| Cancel

lllustration 68: Dialog to
create hyperstacks, i.e.
multidimensional images.

Select Create Composite and press ok. You now see an overlay of the two channels. Open the
Channels dialog from the menu Image>HyperStacks and the Brightness and Contrast
Adjuster by pressing shifi+c on the image. With the slider on the bottom of the stack window
you select the channel to manipulate. If you move it to the right the histogram in the
Brightness and Contrast tool becomes green indicating that the green channel is selected. If
you move the slider back to the left the histogram becomes red again. You can change the
colors by applying lookup tables from the LUT menu. Adjust the display of the two channels
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using the B&C tool. Remark that the display adjustment of one channel remains when you
change to the other channel. You don't need to press the apply button.

You can save a hyperstack and reload it without loosing the display adjustment. Save it in tif
format using File>Save or File>Save As. Close the hyperstack window and reload the saved
file using File>Open.

If you want to create a snapshot of the overlay click on the More button in the Channels
window (Image>Hyperstacks>Channels Tool...) and select Convert to RGB.
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r2; 690x514 pixels, 3-hit, Gadk
_ cha... [E E3
Composite -

¥ Channel 1
v Channel 2

Hlustration 70:

The channel
dialog allows to
< | 2 show and hide
Hllustration 69: The overlay of two selected
channels. channels.
sac MEE
[i] 255 i} 255
] ol i3
Minimum Minimum
Rl ] 4 1]
Maximum Maximum
0 Rl Y I A D )
Brightness Brightness
0 Rl Y I A Dl )
Contrast Contrast
__Auto i Reset Reset
Set Apply Apply

lllustration 71:  Illustration 72:
The B&C tool Changing the
works on the selected channel
selected channel  automatically
and displays the changes the
histogram in the channel on which
color of the the B&C tool
selected channel. works.

Create a second hyperstack from the images dapi 5 and rhod 5. Imagine that you want to
compare the intensities in the two images. To be able to do this you need to set the same
display adjustments for both images. Select the red channel in both images. Adjust the display
for the first image (for example by pressing reset followed by auto), then press the button set.
Select Propagate to all open images and press ok. The display of the red channel in the
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second image has been adjusted in the same way as the one in the first image now. Select the
green channel in both images and repeat the procedure.

d X
Minimum Displayed Value: |10

Maximum Displayed Value: [172

W iPropagate to all open images:

OK Cancel

Hllustration 73: The display
settings can be propagated to
all open images (same
channel).

R - Bl - ]

Hllustration 74: The display settings have Illustration 75: The display settings have
been optimized for the first image. been transferred to the second image.

Create an overlay from the three images b2RFP _gemDeltaC2 blue.tif,
b2RFP gemDeltaC2 green.tif and b2RFP gemDeltaC2 red.tif and adjust the display.

5.5.1 Aligning channels

You can use the composite display to align two channels. Open the images dapi 4.tif and
Rhod 4.tif and create a hyperstack. As you can see the to channels have been shifted against
each other. Use ctrl+a to select the image with the first channel selected, then press ctrl+x to
cut the channel and ctrl+v to paste it again. You can now move the image of the first channel
around. Correct the alignment then select a rectangle around the not empty area of the image
and call Image>Crop to get rid of the border.

5.5.2 Overlay of volume images

We will now display an image with 54 z-slices and 3 channels. Open the images Dapi.stk, the
Gtub.stk and the Actine.stk. Create the Composite image using Image>Color>RGB Merge...
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You now have a window with two sliders, one to select the channel and one to select the slice
in the stack.

 Concatenated Stacks ... !E
CIAE 2RS4 10241024 pixels; 8-bit; 162ME

Hllustration 76: A hyperstack of a
volume image with three
channels.
Two create a composite with more than four channels you can use the command
Image>Hyperstacks>Stack to Hyperstack.

Order:  |xyczt{default)

Channels (c): B|
Slices (z): |54
Frames (t): |1

Display Mode: |Composite -
DK Cancel

Hlustration 77: With the
Stack to Hyperstack
command hyperstacks
with more than 4 channels
can be created.

5.6 Noise suppression

Open the image plant-noise.tif. The image contains a high level of noise. Zoom into the
image. The background should be homogeneous, but it contains a random distribution of
intensities. The same random distribution is added to the signal.
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L plant-noise.tif (800%) E]@

r.d plant-no"lse.tif (25%] E]@ TE001 200 pivels; -bit, 1,818

TEO0:1 200 pixels; 8-hit, 1.8MB

lllustration 79: Pixel values in
background and object are
changed in a random manner.

Hllustration 78: An image with a high level of noise.

There are different possible sources of noise in an image. One kind of noise stems for
example from the digital camera. In the camera incoming photons are transformed into an
electrical charge by a charge coupled device or CCD. However some electrons are created
within the CCD randomly. Another source of noise is the random emission of photons from
your specimen, which is a quantum physical phenomenon.

The noise can pose a problem for the analysis of the image, for example in the separation of
the objects from the background. If we have a light object on a dark background we could for
example look for the lowest intensity value in the object and separate the object from the
background by searching all pixels that have an intensity value higher than this threshold
value. However the noise has changed the intensities in the background and in the object, so
that there are very high intensities within the background and very low intensities in the
object. We might have to pre-process our image to reduce the disturbing effect of noise.

5.6.1 Convolution filter

5.6.1.1 Mean filter

An evident way to smooth our image and to reduce the impact of the noise is to replace each
pixel in the image by an average of the intensities in its neighborhood. This is called a mean
filter in ImageJ. You can find it under Process>Filters>Mean. You have to enter the radius of
the neighborhood in which the average for each pixel is computed. If the radius is 1 the
neighborhood has a size of 3x3 pixels. Run the filter with different values for the radius and
compare the results by zooming into the images. To run a mean filter with the radius 1 you
can use Process>Smooth or Shift+S.
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4 plant-noise.tif (25%) E]@ 1 plant-noise.tif - mean filter (25%) E]@

1600:1200 pixels; 8-hit, 1.8ME 1600:1200 pixels; 8-hit, 1.8ME

Hllustration 80: An image Hllustration 81: The image filtered
containing noise. with a mean filter of radius 1.

Open the image rectangle. You see a filled rectangle with intensity values 255 on a black
background. What will be the intensity values of the edge and corner pixels after applying a
mean filter with radius 1?

. . rectangle.tif - mean ... - |0/
 rectangle.tif (800%) |- OJed 3232 pixels, B-hit, 1K
32%32 pikels,; 8-hit; 1K

Hllustration 82: A white Ilustration 83: Th? white
rectangle rectangle after applying a mean
. filter of radius 1.

Compare the histograms of the original plant image and the plant image after a mean filter has
been applied. Use a large radius, for example 15. Press h on the image or use
Analyze>Histogram to display the histograms of the images.

Use the brightness and contrast adjuster to make the background as dark as possible and the
plant as light as possible.
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! plant-noise.tif (16.7%) = /0OJE3 ! plant-noise.tif - mean ... = |[O/Ed

1600x1 200 pixels; 8-hit; 1.8MB 1600x1 200 pixels; 8-hit; 1.8MB

Hllustration 84: Separation of Hllustration 85: The separation
object and background is becomes possible after application
impossible in the noisy image. of a mean filter.

L

[ | -
0 256 0 256
Count: 1920000 Min: 0 Count: 1520000 Min: 15
Mean: 27.252 Max: 22 Mean: 27.250 Max; 98
StdDev: 23.572 Mode: 2 (48226) StdDev: 14.454 Mode: 20 (701089)
llustration 86: The histogram of [llustration 87: The histogram
the noisy image. after a mean filter of radius 15 has
been applied.

A mean filter can be applied in the following way:
* For radius r create a matrix of size N = 2r+1 x 2r+1 filled with values 1/N.
The matrix is called the kernel of the filter.
* Move the center of the kernel across the image. For each position:
o Multiply each matrix element with the corresponding intensity value and
calculate the sum of the results.
o In the result image replace the intensity of the current pixel with the calculated
result.
A generalization of this technique is called convolution. A convolution is an operation that
calculates the overlap of two functions. In the general case the kernel and the image can have
infinite size.
Instead of simply calculating the average, we can calculate a weighted average by using
different values in the matrix. Convolution filters can not only be used for smoothing but also
for other purposes, for example to enhance edges.
To apply a convolution filter go to Process>Filters>Convolve and enter the matrix in the
dialog. To create a mean filter of radius 1 put in a 3x3 matrix, in which all elements are 1.
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Normally we would have to use 1/9, but we can select the “normalize kernel” option and the
computer will do this for us.

& Convolver...

111
111
111

QOpen.. | Save..

v Mormalize Kernel

OK Cancel

Hllustration 88: Applying a mean
filter by doing a convolution.

Apply the convolution filter. Compare the result with the result from the mean filter. To test
whether the results are absolutely identical you can subtract one result image from the other.
If the images were identical the result image must be all black. Use Process>ImageCalculator
to subtract one image from the other. Apply the hilo lut to the result to see if intensities other
than 0 are present.

£ Image Calculator

Image1: |p|ant—n0ise.tif— mean filter j

Operation: |Subtract -

Image2: |convoived -

[+ Create New Window
I 32-bit Result

0K Cancel

Hllustration 89: Subtracting one
image from another image.

The smoothing reduces the deranging effect of noise but in the same time blurs the object, so
that less details are visible.

5.6.1.2 Gaussian blur filter

A Gaussian blur filter is similar to the mean filter, but instead of using uniform weights in the
kernel, the weights are the values of a normal distribution, also called Gaussian distribution.
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A normal distribution is used to describe random processes. Throw a coin 100 times and
count the times the head is up. Repeat this 1000 times and draw a histogram of the outcomes.
Most of the time you’ll get values around 50, resulting in high bars around 50 in the
histogram. The case that in 100 throws only 1 head turns up will not occur very often. The
same will be the case for 100 heads in 100 throws. If you connect the top points of the bars
you get a curve that looks like a normal distribution and if instead of throwing the coin 1000
times you throw it an infinite number of times you’ll get a normal distribution.

A two dimensional normal distribution has the form of a bell.

1 _-w?
Ppe (3’;) = o o

Hllustration 90: A
gaussian function.

In older versions of ImagelJ the Gaussian Blur filter had the radius as a parameter. In newer
versions (from 1.38q) the parameter is sigma, the standard deviation of the distribution. To get
the same results the values in the old version have to be multiplied by 2.5.

Open the file Gaussian.txt. Here you see the values of a normal distribution. How does it look
like as an image? Open the file as an image by using File>Import>Text Image. Apply the ice
lut. Now go to Analyze>Surface Plot or use the Interactive 3D surface plot plugin
(Plugins>3D) to get an impression of the 3D form. Because of the discrete nature, what you
see looks less smooth then the real form. Besides the real curve never drops down to zero, but
values will be very low outside the central area so that we can use a truncated Gaussian as an
approximation.

i gaussian.txt |- |03 ¢ gaussian.txt (320... - | OJES { Surface Plot (... (= |OJE3d

[ Fle Eat Font Macros 77 pixels, 32-bit, K B10¢510 pixels, ROB; 1.2WE

b o 1 2 1 o
313 2213 3
13 59 97 59 13
22 97 159 97 22
13 59 97 59 13
313 2213 3
001 2 1 0

s

(= S =]
(== & = =]

fe]

Hllustration 91:
Convolution kernel for
a (truncated) gaussian

blur filter. Hlustration 92: The kernel as
image.

Hlustration 93: The kernel
as surface plot.
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445¥426 piels; RGE; 741K

Hllustration 94: The kernel
as a surface plot created
with the «interactive 3D
surface ploty plugin.

Apply the Gaussian blur filter with sigma 1.2 from Process> Filters>Gaussian blur to the
rectangle image and compare the result with the result of the mean filter with radius 3.

i rectangle-1.tif (800%) |- O/&3 i rectangle-2.tif (800%) |- OJ&3

332 pixels; B-hit; 1K 332 pixels; B-hit; 1K

Hllustration 95: Mean filter with Hllustration 96.: Gaussian blur
radius 3 applied to the rectangle filter with sigma 1.2 applied to
image. the rectangle image.

Although both images are blurred, the result from the Gaussian filter looks more like the
original form. The Gaussian filter while removing noise as well, keeps edges better. Apply a
Gaussian blur filter with a sigma of 6 and a Mean filter of radius 15 to the image roots and
compare the results.
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4

! roots.tif - mean f... ; EE . roots.tif - gaussi... ; EE

457891 pixels; B-hit; 442K 4574991 pixels; B-hit; 442K

llustration 97: The roots  [llustration 98: A mean filter  Illustration 99: A gaussian
image. of radius 15 has been applied  blur filter of radius 6 has
to the image. been applied to the image.

Open the plant-noise image. Open the convolution tool and load the Gaussian.txt into it. Run
the convolution filter on the image.

© plant-noise_tif (25%) BEX)

6001 200 pikals, a-bit, 1.8MB

Hlustration 100: The plant image
after the convolution with the
gaussian kernel has been applied.
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5.6.1.3 Edge enhancing filter

Create a convolution filter of radius 1. Put 1 1 1 in the first row, -1 -1 -1 in the last row, and 0
0 0 in the middle row. Apply it to the rectangle image, after having converted it to 32-bit.
Apply another filter with the values above in the columns instead of the rows to the original
32-bit image. Square the result images, add them and apply square-root to the result. This is a
called a Prewitt filter. To see the effect of the filter, create an overlay of the original and the
filtered image, by using Image>Color>Merge Channels. Put the filtered image in the red
channel, the original image in the green channel and choose none for the blue channel.

# Convolver... B & |
& Composite (RGB) (1200%)
3232 pixels: RGB: 4K
111
000
1-1-1
Open... | Save., |
e 2 L Hllustration 102:
- Preview Channel-merge of the
"ok | [Cancal] original image and the
result after application of
lllustration 101: The convolution the filter.

kernal for an edge enhancing filter.

b

& Comp_ & ® ®
1.10%0.92 inches (10

lllustration 103: Detail of the channel-merge of
the roots image and the result from the
convolution that detects contours.

volker.baecker@mri.cnrs.fr 49/93



mailto:volker.baecker@mri.cnrs.fr

IMRI
= N Bi Image processing and analysis with ImageJ and MRI Cell Image Analyzer

| Apply the Prewitt filter to the roots image after having converted it to 32-bit. Using the same

-1 0 1 1 2 1
procedure with thekernels —2 0 2 and 0 0 0 gives the Sobel-filter. In
-1 0 1 -1 -2 -1

Image] the command Process>Finde Edges implements the Sobel-filter.

5.6.2 Rank Filter

Rank filters are another class of filters. Again we look at a neighborhood of radius r for each
pixel. But this time the intensity values are sorted and the pixel is replaced with the value in a
specific position.

If we use the middle position we get a median filter. If we use the first position we get a
minimum filter and using the last position we get a maximum filter.

Open the image plant-sp-noise.tif. Zoom in to the image. You see that in this case the noise
consists of the addition of white and black pixels to the image. This kind of noise is called
salt-and-pepper noise.

4 plant-sp-noise.tif (25%) =J2Ed

1600x1 200 pixels; 8-hit; 1.8MB

Hlustration 105: Salt-and-

pepper noise consisits of the
addition of white and black
pixels to the image.

Hllustration 104: The plant image with salt-and-
pepper noise.

Apply a median filter of radius 3 from Process>Filters>Median to the image. Compare the

result with the result from the mean filter. The median filter is more effective in removing
salt-and-pepper noise.
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¢ plant-sp-noise-1.tif (25%) E]@ 1 plant-sp-noise.tif (25%) E]@

16001200 pixels; 8-hit, 1.8MB 1600:1200 pixels, 8-hit, 1.8MB

lllustration 106: A median filter effectively Hllustration 107: A mean filter is not so
removes salt-and-pepper noise. effective on salt-and-pepper noise.

You can run a median filter with radius 1 using Process>Noise>Despeckle.

In Process>Noise>Remove QOutliers, you find a selective median filter, that replaces a pixel
by the median in the neighborhood if the value of the pixel differs more than a threshold value
from the median. Use it to remove the dark and light components of the salt and pepper noise
separately.

5.6.3 Filtering in the frequency domain

In its normal representation an image consists of an intensity value for each spatial coordinate.
We call this the spatial domain. The same information can be represented in other ways. Some
operations are easier to apply with a different representation.

One important representation is to transform the image into the (spatial) frequency domain.
Here each value represents the frequency of change of the intensity value. Large structures
have a low frequency, small repeating structures have a high frequency. The Fourier
transform transforms the image from the spatial to the frequency domain. The transform is
based on the fact that each signal can be presented as a sum of harmonic (sinoid) functions of
different phase and amplitude. The result is an image of complex numbers that can be divided
in a real part, the power spectrum and an imaginary part, the phase information. From the
result the original image can be reconstructed without any loss by applying the inverse
Fourier transform. Usually only the power spectrum is shown, since it contains most of the
interesting information. However to reconstruct the original image, both, the power spectrum
and the phase image are needed.

There exists an efficient way to compute a Fourier Transform. It is called the Fast Fourier
Transform or FFT. We can use the Fourier Transform to filter our image in the frequency
domain.

One reason why the frequency domain is interesting is because we will be able to recognize
frequencies that appear as clusters visually. We can use this to filter out frequencies that
correspond to objects or patterns of different size in the image.

Low frequencies will be displayed in the middle of the power spectrum and the higher the
frequencies are, the bigger is their distance to the center. If we filter out the low frequencies in
the middle, we apply a high pass filter. This can be used as an edge enhancing filter since the
edges information is in the high frequencies.
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If we filter out the high frequencies, we apply a low pass filter. This has a smoothing effect on
the image, since the fine details have a high frequency.

Another reason why the Fourier Transform is important is because we can calculate a
convolution more efficiently in the Fourier Domain. The Convolution Theorem states that a
convolution in the spatial domain is equivalent to a multiplication in the frequency domain.
Open the image Pierre.tif. Apply the Fourier transform from Process>FFT>FFT.

- - i FFT of pierre.tif (200%) - | O/&3
. pierre.tif (20... - |[OJE3) T28%128 pixels: 6-bit, 16K
Y8116 pixels; RGE; 44K

Hlustration 108: An

. Hlustration 109: The power
image.

spectrum of the image.

You can use the Iut tool to make visible different clusters of frequencies. Do you see the two
clusters in the upper left and lower right quadrant. Draw a selection around the first. Then add
a selection around the second by pressing shift when you start the selection. You can release
the shift key once you started the second selection. Now run the fill command from Edit>Fill
or press CTRL+f.! We have set the intensities in the selection to zero and in this way
suppressed the corresponding frequencies. Apply the inverse Fourier transform from
Process>FFT>Inverse FFT. At first look the image doesn’t seem to have changed. Zoom in
on the image and on the result image behind the ear. You see that the lines of the window
blinds have disappeared in the filtered image, since we suppressed the corresponding
frequencies.

1 Fill actually uses the current foreground color. Double click on the color picker tool and set the current
foreground color to black.
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E]@ L Inverse FFT of pierre.tif (1600%) B@1
(387116 pixels, RGB, 44K

1 pierre.tif (1600%)
(88176 pizels; RGE; 44K

[

L FFT of pierre.tif (200%) - |O/E3

128x128 pixels; 8-hit, 16k

Lllustration 111: Detail of  Illustration 112: Detail of
the original image. the filtered image.

Hllustration 110: Filling parts of
the power spectrum image with
the background color filters out
the corresponding frequencies.

Subtract the filtered image from the input image to see what exactly has been filtered out.
Instead of building the difference you can as well go back to the power spectrum and fill the
inverse of the mask.

. Result of pierre (400%) E]@

93116 pixels, RGE, 44K

difference of the original
image and the filtered
image.

Use Process>FFT>Redisplay Powerspectrum to redisplay the original power spectrum.
Try to smooth the plant-noise image. Which frequencies do you have to filter out?
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! plant-noise.tif (16.7%) (= OJEZ £ Inverse FFT of plant-n... (= 0JE3

LFFT of plant- 16001 200 pixels; 8-bit; 1.8MB

sssssssssssssss :

16001 200 pixels; 8-hit, 1.8ME

Hlustration 114: Using e :
clear instead of fill lets Hlustration 115: The Lllustration 116: The image

the corresponding original image. after filtering in the
frequencies pass. frequency domain.

Try to enhance the edges in the roots image. Always build the difference of the original image
and the filtered image to see what exactly has been filtered out.

i Inverse FFT of ro... |- |0/ TJL Result of roots (5... E]@T

4a7x891 pivels; 8-bit, 442K 4a7x891 pivels; 8-bit, 442K

)

Hlustration 117: The roots Hlustration 118: The

image after a high pass filter difference of the original and
has been applied. the filtered image.
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If we set everything, except for a ring, to zero in the power spectrum, we will filter out all
frequencies higher then a certain value and all frequencies lower then a certain value. This is
called a band-pass filter, since the only frequencies that pass are those within the ring.

Try it for example with the image pierre.tif. Draw a circular selection and then remove a
second circle from within the selection by pressing the alt key while making the second
selection. Use the I from the toolbox to invert the selection and apply fill from the context
menu.

: . ¢ Inverse FFT of pierre.tif (... =
« FFT of pierre.tif (200%) E]@ 98116 pixels, RGE, 44K -0k

128x128 pixels; 8-hit, 16k

lllustration 119: Defining a Hlustration 120: The bandpass
bandpass filter. filter applied to an image.

You can apply a bandpass filter using the command Process>FFT>Bandpass Filter....
root(— (8] 'S reot (@]

119x410 pixels; 8-bit] 116x410 pixels; &-hit|

FFT Bandpass Filter =S
Filter Large Structures Dawn 1o E pixels
Filter 3mall Structures Up 1o (1 pixels

Suppress Stripes:  Bone =

Tolerance of Direction: |30 % N

Filter (16.[_ |[o (x|

1024x1024 pixels, 32-hQit; 4k
_lAutascale After Filtering

WSaturate Image when Autoscaling

W Display Filter

0K Cancel
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Plot of root2 [=JEx] Plot of root2-1 HMEEY

Gray Value
Gray Value

120

0 50 100 150 200 250 300 350 0 100 200 300
Distance (pixels) Distance (pixels)

List Sawe Capy. List Save Copry

5.7 Background subtraction

Open the image nuclei-rhod.tif. Apply the hilo lut. As you see no pixels become blue,
meaning that the background is not zero. Since this image is from fluorescent microscopy,
normally the background should be black, in reality however there is some intensity in the
background.

In this example the background is low and, except for the noise, homogeneous. A high
background can make it harder to clearly distinguish objects. Furthermore if we want to
compare intensities between images with different background levels we have to compensate
for the background.

Use the B&C tool to clearly distinguish a background region. Draw a line selection on the
background and create a profile plot using Analyze>Plot profile or select the image and press
k. The profile plot shows the intensity values along the line selection. You see that the values
vary somewhere between 1 and 9 due to noise and that the average is somewhere around 3.
Press the measure button on the toolbox or select the image and press ctrl+m to get the exact

mean value.

 nuclei-rhod.tif (75%) [ [=1 <
B50x515 pixels; 8-hit; 326K
L Plot of nuclei-rhod E}@
917
§
3
0.74
o Distance (pixels) 453
List | Save..| Copy..
L <. Hllustration 122: The line plot displays the

Hlustration 121: The background should intensities along the selected line.

be black, but contains some intensity in

reality.
Go to Process>Math>subtract and subtract the mean background value from the image. Use

the R button from the toolbox to get back the line selection and create the profile plot again.
This time the values go down to zero. The command Plugins>ROI>BG Subtraction from Roi
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image.

1 nuclei-rhod.tf (75%) 9=

650514 pixels; 8-hit, 326K
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intensity within the selection, from the

4 Plot of nuclei-rhod g@1

617

GrayValue

0.00

0 Distance (pixels)

List | Save..| Copy...

Hllustration 123: The image after the value
3 has been subtracted from each pixel
value..

Hllustration 124: The line plot goes down to
zero now.

Another way to get rid of the background is to divide the image by the average background
value. Most background values will be 1 afterwards and you can subtract 1 from the image to
set them to zero. Try it with Process>Math>divide.

1 after division (50%)

B[=)%]

GBalxa14a pixels; 8-hit, 326k

Hllustration 125: The image after it has
been divided by 3.3 and 1 has been
subtracted.

There is an automatic operation that tries to find and subtract the background. Open the visual
scripting plugin from Plugins>Montpellier RIO Imaging>MRI VisualScripting. Go to
Operations>All and search the Find and Subtract Background operation. Drag it from the list
and press the Options button (O). Set the number of iterations to 1. Run the operation by
pressing the button in the middle. The operation searches for the highest intensity value
around the intensity minima and subtracts it from the image.
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E2 'ffind and subtract background options (- | O/E3
| 2 | find and subtract background | u] | |T| -
? [radius 1 [1.0.-]

Hllustration 126: The find and subtract radius araund the minima to search in.
background operation. (2 [ofrset 1 [0.0,-]

values offset abhove minimum are still regarded as minimurm.

|.T|iteratinns 1 [1.0,-]

number oftimes the procedure is run.

[2/|skip timit 0.05 (0.0,

images where the padion of pixel is already zero are skipped.

Hllustration 127: The options dialog of the
operation.

! nuclei-rhod.tif - find and subtr... - [O/Z3
Ba0xa15 pixels; B-hit; 326K

Hllustration 128: The image after the find
and subtract background operation has
been applied.

5.7.1 Inhomogeneous background

Open the image root2.tif. Draw a vertical line on the background again and create the profile
plot. As you see this time the background baseline is not constant. The image is darker in the
top area and lighter in the bottom area. Measure the mean and subtract it from the image.

Create the profile plot again. You see that, although the background value is lower now, the
gradient is still present.
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1 Plot of root2-1 B=X])

-d: ro--- u@w 1583

T10x410 pixels, 5-bit, 4

Gray Value

113.0

366

o Distance (pixels)

Hllustration 130: The line plot reveals a
gradient from the top to the bottom of the
image.
Pl of roor2 SEx)

ca AMAAMMAAJMW\“M

Distance (pixels)

GrayValue

lllustration 131: After subtraction of the
average background intensity the gradient
is still present.

Hllustration 129:

An image with an

inhomogeneous
background.

Apply the operation Process>Subtract Background to the image and create the profile plot.
The gradient has disappeared. The command uses a rolling ball algorithm that, roughly
described, moves a sphere along the image and considers intensity values outside the radius to
be background. In this way the local information is taken into account.

! Subtract Backgro... | & Plot of root2-1 =[(=1%]

236
Rolling Ball Radius: |ﬁl

[~ White Background

DK | Cancell

Gray Value

Hllustration 132: The M

options dialog of the 00

subtract background 0 Distance (pixels) 360
command. st | save.. | copy.. |

Hllustration 133: The subtract background command
removes the gradient using a rolling ball algorithm.

One very elegant way to remove background is to make an image of the empty scene along
with the image of the specimen. One can than divide the specimen image by the background
image and multiply the result with the mean intensity in the background image . This is often
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possible in microscopy and the technique is called flat field correction. If it is not possible to
take the “empty” image we can simulate the process by applying a very large filter that will
remove the object from the image. We then have to divide the result from the original image
and multiply with the average intensity of the filtered image. This can be done with
Process>Filters>Pseudo Flat Field. Select the keep flat field box to see the generated
background image. Look at the profile plot from the result. Again the gradient has
disappeared. The Pseudo Flat Field correction applies a mean filter to the image. You can do
the same thing using other filters. Try a Gaussian blur filter for example.

! Pseudo-flat f... m

Mean filter kernel size: | 150

Iv Keep flat field:

QK Cancel

Hlustration 134: The
pseudo flatdield
correction options dialog.

iRe... - ]JOJES iFlat [=]Okd

119410 pixels; 32-hit; 118410 pixels; 8-hit; 4

. Plot of flat [_ O] x]

0 50 100 150 200 250 300

Distance (pixels)
List | Save..| Copy.

Hllustration 137: The line plot of the
generated background.

L Plot of Result !Em
’ i " Dis:aﬁnnce (mxg\sim = ”
Ilustration 135: Illustration 136: Tllustration 138: Llneplot aﬁer
The image after The generated pseudo flatfield correction. The
pseudo flatfield background that gradient has disappeared.

correction. is subtracted
from the image.
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5.8 Increasing the apparent sharpness

Open the image hst2.tif from the folder “cells in structures”. Zoom in 2 or 3 times. The image
appears somewhat blurred or unsharp. Duplicate the image with the duplicate button from the
tool box and apply a Gaussian blur with sigma 0.8. Multiply the result with the factor 0.6 and
subtract the result from the original image.

This technique is called unsharp masking. You can use Process>Filters>Unsharp Mask to do
it in one step.

1 Result of hst-2 (400%) 8=

753478 pixels, 8-bit, 317K

{ hst-2.tif (400%) [9=1[X]

759x438 pixels; 6-bi, 317K
g

- " a2 - = v "
Hllustration 139: The image appears Hllustration 140: After applying the unsharp
somewhat unsharp or blurred. mask filter the image appears less blurred.

6. Segmentation

Segmentation is the process of separating the objects from the background and from one
another. The simplest way of segmentation is based on the difference in the intensities of
objects and background. One looks for a minimum and maximum intensity value, so that all
pixels belonging to the objects one is interested in have intensities between min and max and
all other pixels have intensity values below min or above max.

The result of a segmentation is often represented as a binary mask. A binary mask is an image
that contains only two values. The first value signifies that the pixel belongs to the
background and the second signifies that a pixel belongs to the object. In ImagelJ the values 0
and 255 are used. Once we created a masked, we can combine it with the original image, for
example to suppress everything but the objects we are interested in.

Another way of presenting the result of a segmentation is a selection. The selection represents
the borders of the objects we are interested in. A selection itself is not an image. ImageJ stores
the selection together with the image. A selection is called a region of interest or ROI in
ImageJ. We can turn a mask into a selection and vice versa and use the representation the
most practical for a given task. A selection can be created from a mask with the help of the
magic wand or tracing tool. Given a selection, a mask can be created by using fill on the
mask, then inverting the mask and using clear. The command Edit>Selection>Create mask
can be used to create a mask from a selection in one step. The command
Edit>Selection>Create Selection can be used to create a selection from a mask or from an
image on which the lower and upper threshold are set in one step.

6.1 Manual threshold selection

The threshold value(s) can be either chosen manually or automatically by an algorithm. The
most simple automatic thresholding algorithms try to find a threshold that divides the
histogram in a meaningful way.
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Open the image plant.tif. Open the threshold adjuster from Image>Adjust>Threshold or click
shift+t on the image. You can choose between three modes in the threshold tool. The first
displays selected pixel in red and pixels not selected with their original intensities. The second
displays the mask that will be the result after applying the threshold, i.e. background in white
and objects in black. In the third mode, selected pixels are displayed with their intensities,
pixels below the lower threshold are displayed in blue and pixels above the upper threshold
are displayed in green.

! Threshold =J2&d

< plant.tif (16.7%) [~ JEJEd | - plant.tif (16.7%) [B[=]X]

1600x1 200 pixels; B-hit, 1.5MB 1600x1200 pixels; 8-bit, 1.8MB

! plant.tif (16.7%) EEE

16001 200 pixels; &-bit, 1.GMB

Hlustration 142: Illustration 143: llustration 144:
Object red, Object black, Object

background background graylevels,
Hllustration 141: The threshold black. white. background blue

adjuster. (below first
threshold) and
green (above
second

threshold) .

Adjust the threshold to select the plant. The wand tool works together with the threshold tool.
So if you want to select the plant, there is no need to create the mask. Use the wand tool to
select the plant. Use the alt key to keep out the two holes between the leaves. You can add to
a selection by using shift and subtract from a selection by using alt. Alternatively you can use
Edit>Selection>Create Selection after you changed the lower and upper threshold with the
threshold adjuster. In contrast to the create selection command, using the wand tool allows to
select one separated object in an image containing multiple objects.

If you press the measure button on the toolbox or the m key on the image, you get a result
table with measurements of the selection.
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& plant.tif (25%)

=k

TB001 200 pixels; &-bit, 1.GME

Hlustration 145: Selection created with the
threshold adjuster and the wand tool.
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1 Results

ok

File Edit

Font

|Area

[Mean

Min |max |

-

4

1 460673 45.640 0O 197

pad
|

lllustration 146: Results table with
the measurements from the selection.

Remove the selection by clicking on the N button in the toolbox. Run the Particle Analyzer to
measure all objects with intensities between the selected thresholds. Use the Apply button if

you want to create a mask.

4 Analyze Particles

Size (pixel*2); |0-Infinity

Circularity: |0.00-1.00

Show: |Outlines -

¥ Display Results [ Exclude on Edges
v Clear Results [ Include Holes
™ Summarize [ Record Starts

0K Cancel

Hllustration 147: The particle

analyzer.

You can filter out objects by their size and circularity and you can create a mask image or an
outline image containing the contours of the measured objects. In the later image the objects
will be numbered, as well. You can choose to exclude objects touching the image borders and
to include or not include holes in the objects in the mask.
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< plant.tif (25%) E]@ r_é Drawing of plant.tif (25%) E]@

1600x1200 pixels, 8-hit (inverting LUT), 1.8MB T600:1200 pixels, &-hit, 1.8MB

Lllustration 148: A mask for the Lllustration 149: An outline of the
plant image. plant created with the particle
analyzer.

You can configure the values that will be measured by the Particle Analyzer under
Analyze>Set Measurements or under Options>Measurements on the toolbox. Here you can as
well configure a redirect image. In this way you can use a mask but the intensities will be
measured in the redirect image, for example the original image the mask was created from.
Use the Particle Analyzer to measure the plant with the intensity values from the original
image and display the outline result.

_'; Set Measurements EJ

V¥ Area ¥ Mean Gray Value
[ Standard Deviation [}
v Min & Max Gray Value ¥ Centroid
[” Center of Mass ™ Perimeter
[~ Bounding Rectangle [~ FitEllipse

[~ Shape Descriptors [ Feret's Diameter
[~ Integrated Density ™ Median

[~ Skewness ™ Kurtosis

[~ Area Fraction [™ Stack Position

[ Limitto Threshald [ Display Label
[ Invert ¥ Coordinates [ Scientific Notation

Redirect Ta:  |Mone hd

Decimal Places (0-9y |3

0K | Cancell

Hllustration 150: The set
measurements dialog. The settings
are used by the measure command

and by the particle analyzer.

Another way to use a mask to measure in another image, is by using the wand tool on the
mask and then transferring the mask to the other image by activating the image and pressing
R on the toolbox or shift+e on the image. You can then use the measure command to measure
the content of the selection.
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Open the plant-noise.tif image and try to segment it with the help of the threshold adjuster.
You will see that the noise prevents you from making a good segmentation. Try one of the
noise suppression techniques we discussed and try the segmentation again.

6.2 Measurements and the ROI-Manager

Open the image 44 dapil.tif. Set a threshold that separates the nuclei from the background.
Run the Particle Analyzer. Select the Add to Manager option. For each particle detected by
the Particle Analyzer, a roi is added to the ROI-Manager. The Show All button shows or hides
all rois in the manager on the active image.

If you click on one roi in the list, it will be set to the active image. Clicking on a label of a roi
in the image, selects the roi in the list. Now deselect all rois and press the measure button.
You get a results table with the measurements of all rois. If you select a number of rois using
shift, only the selected rois will be measured. In general the commands in the roi manager are
either applied to the selected rois or to all rois if there is no selection.

. A4 dapi 1.tif (75%) ! ROI M... !EE
650x515 pixels, 8-hit; 327K
0003-0089 Add [
0004-0114 —
0005-0126 Update
0006-0160 Delete
0007-0213 .. [y |
0GE-0237 i Rename
0009-0305 Open
0010-0301 _
0011-0366 Save
0012-0361 Measure
0013-0457 _—
Deselect
Show All
More =

lllustration 152: The

rois of the particles

lllustration 151: The roi manager have been added to
displays the rois of all particles.  the roi manager.

! Results !E m

File Edit Font

[arez [Mean  [StdDev [Mode [Min [Max [X [ [p [ym [Perim. [ =
8117 126136 25661 116 63 222 1951381 S6.632 199.346 B6.768 392.818
7060 148.329 31552 157 71 239 428751 113516 428085 113451 330534
5502 126.573 24.370 116 66 191 43222 126.345 42816 126213 294.635
5494 125617 27222 135 62 235 199802 161.013 200499 181116 292.149
7532 145791 32.992 150 71 246 353093 213.308 353442 212643 327.948
5661 135.269 24.036 145 71 193 64848 237.529 65243 237119 300.735
192 131989 25303 132 71 211 552580 305.328 551915 304752 305.806
4604 138906 31.713 130 63 224 267910 300179 267436 299.965 299.806
B969 122.956 26.279 126 59 210 497842 459.132 499.617 459511 340.274 .
7324 166683 36.564 167 71 255 960952 365877 360801 965956 331463

Hllustration 153: The measurements of the rois in the roi
manager.

= @0 m - m W oW =

- o

v
i

Remove particle 10 and 9. Use the wand tool to select particle 10 again and add it again to the
roi manager.
Save all rois, then close and re-open the roi-manager and open the saved rois again.
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Compare the measured values of different particles. What is the meaning of the measured
values?

Area:
The surface of the roi. It is measured in square-pixel if no spacial scale is set.

Mean:
The average gray value within the roi.

StdDev:
The standard deviation of the mean gray value within the roi.

Mode:

The most frequently occurring gray value within the roi. This corresponds to the highest peak
in the histogram of the roi. If you display the histogram the mode will be shown together with
the number of occurrences.

Min:
The minimal gray value within the roi.

Max:
The maximum gray value within the roi.

The x-coordinate of the centroid. This is the average of the x-coordinates of the pixels in
the roi.

The y-coordinate of the centroid. This is the average of the y-coordinates of the pixels in
the roi.

XM:
The x-coordinate of the center of mass. This is the brightness weighted average of the x-
coordinates of the pixels in the roi.

YM:
The x-coordinate of the center of mass. This is the brightness weighted average of the y-
coordinates of the pixels in the roi.

Perim. :
The length of the outside boundary of the roi.

BX:
The x-coordinate of the upper-left corner of the bounding box of the roi. The bounding box is
the smallest rectangle, that entirely contains the roi.

BY:
The y-coordinate of the upper-left corner of the bounding box of the roi.

Width:
The width of the bounding box of the roi.

Height:
The height of the bounding box of the roi.

Major:
The length of the major axis of the best fitting ellipse. The ellipse has the same area,
orientation and centroid as the original selection.

Minor:
The length of the minor axis of the best fitting ellipse.

Angle:
The angle of the major axis of the best fitting ellipse against the x-axis of the image.

Circularity:

4u (area/perimeter”~2). A value of 1 indicates a perfect circle. As the value approaches 0, it
indicates an increasingly elongated polygon. Values may not be valid for very small particles.
The perimeter of a circle is p = 2nr and the area is a = nr?.
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Feret:

The longest distance between two points on the boundary of the roi. You can use the macro Draw
Ferets Diameter to draw the feret diameter of a selection into the image. Use
Plugins>Macros>Install and select the macro from the macros folder in the ImageJ base-folder.
Make a selection in the image and call the macro from the Plugins>Macros menu.

IntDen:
The integrated density is the sum of the gray-values of all pixels within the roi.

Median:

The median gray value of the pixels within the roi, i.e. The gray value that lies in the
middle or the value between the two values in the middle, when all gray-values are sorted by
their numerical value.

Skewness:

A measure of the asymmetry of the distribution of the gray values around the mean within the
roi.

A _a

|

-118.323 123935 0 4246 -1.634 2612

Count 640000 Min:-118.323 Count: 640000 Min: 0 Count: 640000 Min:-1.634

Mean:-0.030 Max; 123,935 Mean: 1.137 Max: 4.246 Mean: 1.475 Max 2.612

StdDev: 24.995 Mode:-2.399 (9761) StdDev:1.222 Mode: 0.008 (320442) StdDev: 1.222 Mode: 2,604 (320442)

Bins: 256 Bin Width: 0.946 Bins: 256 BinWidth: 0.017 Bins: 256 Bin Width: 0.017

Value: -105.075 Value: 1.443 Value: 0.323

ust| copy| Log| List| Copr| Log| e Lst] Copy| Log| e
Hlustration 154.: Hlustration 155: Hlustration 156:

The measured The measured The measured

skewness is 0.001 skewness is 0.345 skewness is -0.345

Kurtosis:

A measure of the "peakedness" of the distribution of the gray values around the mean within
the roi. Higher kurtosis means more of the variance is due to infrequent extreme deviations,
as opposed to frequent modestly-sized deviations.

%Area:

The percentage of the surface that has an intensity value above the min-threshold or above 0
if no min-threshold is set. Loosely speaking this is the percentage of pixels within the
object that do not belong to holes.

FeretAngle:
The angle of the feret diameter with the x-axis of the image (0-180).

MinFeret:

This is a measure of the particle's width. It is called the minimum caliper diameter as well.
It is defined as the shortes distance between two parallel planes touching the particle on
opposite sites, for any orientation of the particle.

AR:
The aspect ratio of the particle. This is the length of the major axis divided by the length
of the minor axis of the fitted ellipse.

Round:

The roundness of the particle, defined as: 4*area/n* (major axis)?. The roundness is 1 for a
circle and approaches 0 for very alongated objects. The major axis of a circle is p = 2r and
the area is a = mr?.

Solidity:

The area of the particle divided by the area of the convex hull of the particle. You can see
the convex hull that is used by creating it from a selection using Edit>Selection>Convex Hull.
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6.3 Computed thresholds

Open the plant.tif image again. We will now have a look at the automatic threshold
operations. Open the MRI Visual Scripting Tool. Go to Operations>basic>segmentation. Try
the auto-threshold, the entropy-threshold, the mean-threshold and the otsu-threshold. Which
one gives the best result? Try them on the root2.tif image. Which one gives the best result for
this image?

! plant.tif - auto thresh... (= ][OJEY

1600x1200 pixels; B-hit; 1.BMB

! plant.tif - entropy thre... [~ |OJEd

1600x1200 pixels, B-bit; 1.8MB

. plant.tif - mean thresh... [ |[TQJEJ| | . plant.tif - otsu thresho... - [OJEd
16001200 pixels, B-bit, 1.8MB [TBO0¥T200 piwels, &-hiL T.8ME |

Hllustration 157: Hllustration 158: Hllustration 159: Hllustration 160:
Result of the auto- Result of the Result of the mean-  Result of the Otsu-
threshold. entropy-threshold. threshold. threshold.

The auto-threshold separates the histogram in a way that the threshold value equals half of the
sum, of the average background and the average object intensity. In other words it is trying to
find a threshold in a way that half of the average intensity belongs to background and half of
it to objects.

The entropy threshold searches a threshold value for which the inter class entropy is maximal.
The Otsu threshold uses a threshold value for which the inter class variance is maximal.

The mean threshold uses the mean intensity of the image as threshold value.

6.4 Segmentation of more then 2 object classes

We can have more then two classes for background and objects. We could for example have
background, dark objects and light objects.

Go to Plugins>Segmentation>k-means-clustering and apply it to the plant image, using 4
classes. The result is an image with the intensities 1, 2, 3 and 4. Pixels with a similar intensity
are marked with the same number. We could now multiply the image with 60 and then use the
threshold adjuster to create a mask from each of the numbers. Two binary masks can be
combined by using Process>Image Calculator>And.
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. RGB (33.3%) ][=1]<|

1600x1200 pixels; RGE; 7.3MB

Hllustration 161: Image segmented into
four classes: 1. background - black, 2.
dark areas - blue, 3. brighter areas -
read, brightest areas - green.

The k-means clustering works for color images as well. Try it on the image flamingo.png and
on one of the images from the plant robot folder. Use a bigger number of classes (about 15)
on the later.

The k-means-clustering interprets the intensity values in n-colors as coordinates in an n-
dimensional space. Each cluster is represented by its centroid. Centroids are initially
randomly set and optimized afterwards. Pixels are grouped by their proximity to a cluster’s
centroid.

6.5 Watershed segmentation

Open the image two-circles.tif. Apply a threshold. Now there are two objects touching each
other and we want them to be separated. This can be done using a binary watershed. Apply it
from Process>Binary>Watershed.

& two-circles.tif (75%) (=[5 & two-circles.tif (75%) =)=

400400 pixels; 8-hit {(inverting LUT); 196k 400x400 pixels, 8-bit {(inverting LUT); 156k

Hllustration 162: The thresholded lllustration 163: The binary
image contains two objects watershed algorithm separated
touching each other. the two objects.
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Starting from the binary image a distance map is computed. This gives a grayscale image
where the intensities represent the distance from the border for each object. You can create
the distance map from the original image with Process>Binary>Distance Map. Imagine the
intensity values as height above the ground. This way the image becomes a landscape with
mountains in places of high intensities and valleys in places of low intensities. Apply
Analyze>Surface Plot or use Interactive 3D surface plot plugin (Plugins>3d) the to see the
image this way. The watershed slowly fills the image with water starting from the level 0 and
going up one level in each step. In the beginning some separated basins will be created.
Whenever the rising water unites two basins a dam is build and remembered.

4 two-circles.ti... E]@

400x400 pixels; 8-hit {nverting LUT); 1

Hllustration 164: The distance
map, pixels within the object Hllustration 165: The distance
are darker, the further away map as a surface plot.

from the border they are.

The watershed can be used with a grayscale image directly. To try this we need to install the
watershed plugin from http:/bigwww.epfl.ch/sage/soft/watershed/.

Download the zip, copy it into the plugins folder and unzip it. Restart ImageJ. Now let’s try to
segment the image compartments-1.jpg with the help of the watershed. Open the image and
start the plugin from Plugins>Watershed>Watershed. Use a high value for the smoothing.
Press the Smooth button. Invert the result image so that the basins are dark, using Edit>Invert
or shift+I on the image. Select 8-connected. This means every pixel has 8 neighbors, 2 above,
2 below and the 4 corners. Run the watershed.
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L Dams g@‘

Hllustration 166: The red lines represent the dams
found by the watershed. The image is slightly

oversegmented.

Can you get a better result by applying an edge enhancing filter? Try Process>Find Edges or
shift+f on the image before using the watershed.

7. Image types and formats

7.1 Spatial resolution

The optical resolution is defined as the shortest distance between two points on a specimen
that can still be distinguished by the observer or camera system. For a microscope the
resolution depends on the wavelength and the numerical aperture of the objective. The
resolution is the wavelength divided by 2 times the numerical aperture. Smaller wavelength
and higher numerical aperture yield higher resolution.

The pixel size in an image taken with a microscope and a ccd camera is the product of the size
of a single ccd element multiplied by the binning used and divided by the overall
magnification factor.

The more pixels an image has, the higher can be the resolution, though the number of pixels
alone doesn’t tell anything about the actual resolution. The more pixels an image has, the
larger will be the file size in the same time. By how much the file size grows with the number
of pixels, depends on the bit-depth of the image. Eight-bit images store intensity values
between 0 and 255. Each pixel is stored in 8 bits or one byte. If the image has 400x400 pixels
the size will be 400*400 = 160000 bytes or about 156kb (1kb = 1024b). If we double the size
of the image to 800x800 pixels the file size will be four times as large, i.e. 625kb. If we take
four times the pixels in x and y direction the file size will be 16 times as large.

7.2 Image types

In ImagelJ there are the following basic image types available:
» 8 bit grayscale images (values from 0 to 255)
* 16 bit grayscale images (values from 0 to 65535)
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* 32 bit floating point number images (uses signed floating point numbers)
» 8-bit color (values from 0 to 255), an 8 bit image with a lookup table
* RGB Color (3 channels of values from 0 to 255, bit depth 24)

What happens if we convert an 8-bit grayscale image into a 16-bit grayscale image? Try it!
Open the image cells2.tif and look at the histogram (press h on the image). Then convert it to
16bit using Image>Type>16 bit. Display the histogram again. As you see the intensity values
have not been changed.

7.2.1 Conversion from 16 to 8 bit

Open the image PAX Noc30.tif now. Display the histogram. This is a 16 bit image
containing values from 1000 to 35678. What will happen when we convert it to 8bit? Use
Image>Type>8 bit. The values have been scaled down from the min/max values 1000 and
35678 to 0 and 255.

1 PAX_Noc30.tif (25%) =] >

120001030 pixels; 16-hit, 2.6MB

1 Histogram of PAX_Noc30 [-JEEd | ! Histogram of PAX_Noc30 =]

I 00000
1000 35678 0 256
Count: 1339000 Win: 1000

Mean: 3632.847 Iax: 35678

Count: 1339000 Min: 0

StdDev 2263513 Mode: 1014 (121783) s m:’;;%ﬁmﬂsm

Bins: 256 Bin Width: 135.481
L] | o] ST ] o ]
Hlustration 168: The Hlustration 169: The

. histogram of the 16-bit histogram after
Hllustration 167: The 16-bit images image. conversion 1o 8-bit.
contains intensity values from 1000 to
35678.

In Edit>Options>Conversions you can turn the scaling off. However then all values above
255 will simply be truncated when converting to 8 bit. The result image will be all white,
since the smallest value in the original image is 1000.
Compare the histograms of the results of

* Converting the 16 bit image to 8§ bit

* Use Process>Enhance Contrast>Normalize on the 16 bit image before converting to

8 bit.
* Convert the 16 bit image to 8 bit and do the normalization

7.2.2 RGB Images

Open an image from the plant robot folder. For color images there is a profile tool as well.
Draw a line across the plant and the earth and call Plugins>Color Functions>RGB Profiler.
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! Pot104Cycle0091.jpg =JOEd
352:280 pirels, ROB, 364K ! Profiles of Pot104Cycle0091.jpg (=15
| 520x250 pixels; RGE; 504K

256

Yalue

203

0 Distance

Hllustration 171: The color profile along the line.

Hllustration 170: An RGB-color image.

An RGB image can be split into its three components with /mage>Color>RGB Split and two
or three 8-bit grayscale images can be combined into an RGB color image.

Besides this, an RGB image can be converted into a RGB stack or into a HSB stack using the
type menu. HSB stands for hue, saturation and brightness.

! Pot104Cyc... - /[OEF | ¢ green (50%) (- [|OEF| ¢ blue (50%) (-] OJE4

3500280 pixels; B-hit; 96K 3500280 pixels; B-hit; 96K 3500280 pixels; B-hit; 96K

Hlustration 172: Red Illustration 173: Green [llustration 174: Blue

component of the component of the component of the
image. image. image.
L hue (50%) (= /[OEd| ¢ saturation... [= [OJES | ! brightness... =]
352x280pixels; A-hit; 96k 352}{20 pixels; B-hit; 96K 3592%280 pixels; 8-bit; 96K

a T

Hlustration 175: Hu Hlustration 176: Hlustration 177:

component of the Saturation component Brightness component
image. of the image. of the image.

An RGB image can be converted into an indexed color image. You can choose the number of
colors that will be used and a lookup table will be created accordingly.
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Create two images of same size and draw a white rectangle on a dark ground into the two
images in a way that the two rectangles are overlapping when the images are combined.
Apply rgb merge and put the images into the red and into the green channels. What will be the
color of the overlapping region?

! RGB-1 =Jo&d

209210 pixels; RGE; 168K

Hlustration 178: Green and
red mix to yellow in an
additive color model.

7.2.3 File Formats

Open an image and save it as jpg, using File>SaveAs>Jpeg. Open the jpg file, and calculate
the difference between the jpg version and the original image. What has happened? If you
look at the file sizes you’ll see that the jpg version is smaller than the tiff version. Jpg is a
compressed format. There are lossless and not lossless compressions. Jpg uses the first
scheme. Some information is sacrificed in order to achieve a smaller image in which the
difference is not too much visible for human beings. This is similar to mp3 audio
compression.

8. Image Analysis

For our purpose we can define the term image analysis in the following way:
e [mage analysis is the extraction of meaningful information from digital images by
means of digital image processing techniques.

8.1 Counting objects

8.1.1 Counting objects manually

Open the image nuclei.tif. How many nuclei are there in the image? The cell counter plugin,
written by Kurt De Vos helps to count objects manually. Open the cell counter from
Plugins>Paricle Analysis>Cell Counter. You first have to press the initialize button to
activate the cell counter on the current image. You can count different classes of objects in the
same image. Select a counter type and click on a nucleus in the image. The nucleus will be
marked with a number corresponding to the selected class and the count of the class will be
incremented by one. If you select delete mode a click deletes the nearest marker of the
selected class and decrements the counter of that class.

Once you marked all objects you can use results to get a table with the count for the different
classes. You can save the markers independent from the image and load them later on again,
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either on the same, or on another image. Export image creates an image where the markers are
drawn into the image. You can save this image to show which cells you counted, however in
contrast to saving the markers, you can't continue the counting later on with the exported
image.

< Cell Counter (=)

4 Counter Window - nuclei.tif (33.3%) =J2&d Counters Actions
13001030 pixels; &-hit; 1.2MB

® Type 1 |31 [ | Keep Original

O Typed | O Add
O Typea | 0 Remove
) Typesd | O
) Type6 | O
[ ] Delete Mode
) Type? | O
Results
Reset
[v] Show Numbers

Save Markers

Load Markers

Export Image
Hlustration 179: Nuclei ;nail’ked with the cell counter Tllustration 180 The cell
ool.

counter tool.

8.1.2 Counting and measuring separated objects automatically

Use the threshold adjuster to create a mask from the nuclei image. Then go to Analyze>Set
Measurements and make sure that centroids is selected. Open the Particle Analyzer from
Analyze>Analyze Particles or from the toolbox.

¢ nuclei-1.tif (16.... = [OJE3 i s
1300x1030 pixels; 8-hit; 1.3MB
Size (pixel*2). | 1000-Infinity

Circularity:  |0.00-1.00

Show: lm

|« Display Results | Exclude on Edges

[¥ Clear Results ¥ Include Holes
¥ Surnmarize I Record Starts
Hlustration 181: The mask ok | cancel|
created Wl?h the tresjold Hllustration 182: The particle
adjuster.

analyzer.
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You can exclude particles by their size and circularity. Put in a minimum size of 1000. Select
outlines in the show field and select Display Result, Summarize and Include Holes. As a result
you get a results table with the measurements for each particle, a results table with the
summary and an image of the numbered outlines of the particles taken into account. You find
the total number of objects in the summary results table.

. RGB (=)

1300x1030 pixels, RGE,; 5.1MB

i Summary of n... |- |0JE3

File Edit Font

-

Threshold: 255-255
Count: 47

Total Area: 221467 .000 pixer2
Average size: 4712.064 pixel”2
Area Fraction: 16.540%

d| [
Hlustration 184: The
summary of the
measurements includes the
total count.

13

lllustration 183: Detail of the overlay of
the original image and the outlines of the
particles taken into account by the particle
analyzer.

As an alternative to using the outlines to mark which particles have been taken into account,
you can use the Analyze>Label command to stick a number to each object. This is only
possible if you configured the particle analyzer to measure the centroids of particles.

8.1.3 Counting and measuring objects touching each other automatically

8.1.3.1 Statistical approach

It can be difficult to separate objects touching each other. One approach to count them is not
to try to separate them, but to measure the total area and to divide the result by the average
area of a particle. Open the image si3 hoechst 1.tif from the count cells folder. Convert the
image to 8 bit and apply a threshold. To estimate the average size of a particle use the wand
tool to select singular particles and measure their area. You can use Analyze>distribution to
get the average of a column of the results table. Then use the particle analyzer to measure the
total area of all particles. In case you don't need to exclude small particles that don't represent
cells, you can use Edit>Selection>Create Selection and measure the selected area.
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 Mask of Outlines - split and... [ [C0JEJ
13021040 pixels; 8-bit, 1.4ME.

1

Hllustration 185:
Particles bigger
then the average
pariticle size are
counted multiple
times.

8.1.3.2 Local Threshold

Sometimes unsharp masking can help to separate particles. Try the local threshold plugin

from Plugins>Segmentation>Local Threshold on the image hst-0.tif in the cells in structures
folder. The plugin applies a median filter and subtracts the result from the original image. The
result image is a 32 bit image. It then lets the user choose a threshold value.

sssssssssssssssssssssssss

* hst-0.tif {50[=1 % |

Hllustration 186: The original image Hlustration 187: The image afier

with a threshold. application of the local threshold
plugin.
8.1.3.3 Watershed

We can use the greyscale watershed plugin to separate the cells in the Asz-0.¢if image.

Invert the image, so that the nuclei are dark and the space around them is bright. Use a small
radius for the smoothing filter. Select the show the watershed dams only option. Run the
watershed. Invert the watershed image and subtract it from the original As#-0.¢if image. The
borders between the cells are now set to zero and you can use the threshold adjuster to get a
mask for the separated cells.
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{ Result of hst-0 (200%) []=%]
759¢428 pixels, B-bit, 317K

{ hst-0.tif (200%) []=%]

xxxxxxxxxxxxx 55, 317K

lllustration 188: The original image. Hllustration 189: Cells separated by
the watershed plugin.

© Result of hst-0 (200%) S=]X]

i, 317K

xxxxxxxxxxxxx 5Bt

Hllustration 190: Image with
watershed dams.

8.1.3.4 Other methods

Other methods use for example first or second order gradients of the image or mathematical
morphology.

8.2 Comparing intensities

Open the image A4 Rhod 1.tif. We want to compare the total intensity in the nuclei with the
total intensity in the cytoplasm. The image A4 dapi 1.tif helps us to find the nuclei. Apply the
hilo lut to the rhod image and subtract a baseline value, so that the empty background
becomes zero. Threshold the dapi image. If there are holes in the mask of the nuclei use
Process>Binary>Fill Holes to close them. Create a selection from the mask and if necessary
modify the selection, so that it only contains the nuclei. Transfer the selection from the mask
image to the rhod image using Edit>Selection>restore or CTRL+Shift+e. Configure the
measurements to include the total intensity. And measure the intensity in the selection
(ctrl+m). Inverse the selection (Edit>Selection>Make Inverse) and measure again.
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. A4 Rhod 1.tif (50%) =Jo&d

Hllustration 191: Measuring the intensity
in the nuclei and in the cytoplasm.

8.3 Classifying objects

Sometimes you might not only want to separate objects from the background and from each
other but also to distinguish between different kinds of objects in the image. One could for
example be interested in distinguishing between normal and apoptotic cells. To do so you
need to find a set of features that separates the different classes of objects you are looking for.

Load the image ovals and triangles and try to separate the ovals from the triangles. In this
case the two classes can be distinguished by the feature roundness. Use the particle analyzer
to separate the two classes of objects.

& Untitled (50%) E]@ 4 Drawing of U... E]@ « Drawing of U... E]@

400400 pixels, 8-bif, 156K 400%400 picels; 8-Bit, 156K 400%400 picels; 8-Bit, 156K
® .
® )

- NV

‘e |

P
A
Hllustration 192: Different  [llustration 193: Ovals  Illustration 194: Triangles

kinds of objects in one have a high roundness. have a low roundness.
image.

s
NS

In general more then one feature might be necessary to classify objects. One useful set of
features are the moments of objects and values derived from moments of objects. You can use
the Moment Calculator plugin (Plugins>Particle Analysis>Moment Calculator) to compute
them.
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 Results E]@

File Edit Font
[Image [Area [wean[mifMax[Cutoff [Factor [Mass  [xC Ve weivar  [wvar  [wivar |xSkew[ySkew[xkurt [ykurl [Orient. [Elong
[ Thu Nov 02 13.07.22 CET 2006 |
Mo spatial calibration [results in pixels]
Mo density calibration [uncalibrated results)

1 ovals and triangles tif 2965 0 oo o 1 206040 214500 46500 948589 382025 0 o o -1.838 -1835 0 6.6133221E10

2 avals and triangles tif 3824 0 oo 0 1 264180 90 210 1296.621 464767 0 0 0 -1.841 -1838 0 1.82807249E11

3 ovals and triangles tif 6786 O oo o 1 465120 326500 341 1763.904 1075648 0 o o -1.840 -1840 O 2.20324584E11

4 ovals and triangles tif 3492 0 oo 0 1 894540  103.766 83.364 1234360 316915 -10672 0.185 0698 -1.627 -0.308 -0.666 7.5334735E11

5 ovals and triangles tif 4197 0 oo o 1 1471605 260147 137.592 800.791 1290682 -76.245 0.398 -0.392 -1.216 -1.248 -81355 3.87395944E11

& avals and triangles tif 2512 0 oo o 1 734910 200281 280.826 1001.385 301.730 -18412 0.239 -0629-1515 -0774 -1806 360758149E11 _|

o fie
Hlustration 195: Features based on moments of the circles (first 3 rows) and triangles (last
three rows) .

Further features can for example be calculated with the Particle8 Plus or other morphological
plugins from Gabriel Landini (Plugins>morphology> Particles8 Plus).

£ Clipboard E]@

7370x150 pixels, RGE, BOOK
CountCorrect |A5pRat|U Circ Roundness |ArEquivD  |PerEquivD  |EquivEllAr | Compactness |E‘.U\|mly |Cuncavny |Cunvex\ty |E‘.hape RFractor ModRatio ‘Sphenmty ‘ArEEux
14126087 16573419 0833441 08296095 6049207 91482263 2931106 07934794 09863506 38.0 0855862917 15077697 08311676 0E286199 08296188 37320
1.6183733 14487293 055073977 04360048 6553348 10736593 53155747 0.6618193 097216862 965 09661557 22817257 06616152 04608419 040049228 A766.0
1.7893784 1.7893128 049463472 03334843 7192034  1293.1339 64229863 0.0945454 09721225 1163 09532429 25403322 0.8079261  0.38874095 0.300429%4 B178.0
14933727 16480563 081468574 085841252 6861263 1183.7944 579B8.1855 077079517 098776822 46.0 059846544 15421021 081514865 0859377784 059377784 48360
1.525703 1.7634408 05260764 036003933 55411346 767.6043  3790.1845 0.6000329 09743434 6335 09733579 2388697 0.00540156 0.36512804 0.31091702 4836.0
1.7082019 1.2717441 08750348 077439785 92.03037 21173975 67544243 08799938 09835864 700 085821979 14360995 089577025 07745258 07745258 86000

Lllustration 196: Further features of the circles (rows 1, 4, 6) and triangles (rows 2, 3, 5).
9. Annotating images

9.1 Scale bar, time stamper and event stamper

Open the image Pot.tif. This opens a stack of image which represents a time series. You can
cycle through the images with the slider at the bottom of the window. We want to add three
annotations to the images: A scale bar indicating the length of a known distance, the time
point from the beginning of the series and a marker for images in which the flower appears.
To add a scale bar we first have to calibrate the image. We either need to know the pixel size
or the length of an object in the image. Let's say that the diameter of the pot is 6cm. Make a
line selection from one side of the pot to the opposite side. Then open Analyze>Set Scale....
Enter the distance 6 and the unit cm and press ok. When the scale is set ImageJ will use for all
measurements, i.e. results will now no longer be in pixel but in cm.
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i Pot.tif =Jo&d

107 (Potl 04Cycle0083); 7.91x6 28 cm (352%280); RGE; B.4MB
aEg ! Set Scale

Distance in Pixels: |267.000

Known Distance: IG
Pixel Aspect Ratio: ITU
: Icm

Unit of Length

Scale: 44 500 pixelsicm

Hllustration 198: Setting the scale.

T e

Hllustration 197: Selecting a known distance.

Go to Analyze>Tools>Scale Bar and put a black scale bar of 2cm length into the lower left
corner. Select Label all Slices to put the scale bar into all images of the series.

! Pot.tif [[=0% i ScaleBar Plus
137 (Pot1 04 Cyele009a), 7914629 cm (392x280); RGE; 6. 4MB

Width in cm:
Height in pixels:
Font Size: |1

o
—
e

Color:

Background:

Location: |LowerLeﬂ -I

v Bold Text [ Hide Text
[~ Serif Font
v Label all Slices

OK | Cancell

Hlustration 200: Adding a
scale bar to each image of
the series.

r 2cm

| _ i

Hllustration 199: The black line segment has
a length of two centimeter.

We will now add a text indicating the time when the image was made. Let's say the image
have been made with an interval of 1 day between to images. Make a rectangular selection in
the place where the stamp should appear. Double click the pipette icon and set the foreground
color to the color you want the stamp to have. Then open the time stamper from
Plugins>Movie>Time Stamper.
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! Pot.tif =]

- - 7A7 (Potl04CycleN0R), 7 91x6 28 o (35242803, RGE; B 4ME
4 Time Stamper v B =

Starting Time:

Time Between Frames:
X Location: |173

¥ Location: |1

Font Size: |17

Decimal Places:

LRRRRE

Suffix;:  |days

OK | Cancel

Lllustration 201: The time r S
stamper dialog.

[

Hllustration 202: The time stamp has been
added to each image of the series.

Finally add a label blooming on the slices 14 to 17. This is done in a similar way as adding the
time stamp, only that the command Plugins>Movie>Event Stamper is used.

! Pot.tif =] >

1417 (Fot1 04Cycle0086), 7.91x6.249 cm (352x280), RGE, 6.4MB

! Event Stamper . 13 days

Text. |blooming

‘Starting Frame:
End Frame:
X Location:

Y Location: |5

AT

Font Size: |29

0K | Cancel

Hllustration 203: The
event stamper dialog. A 4
Hllustration 204: A text has been added to
some images of the series.

[

9.2 Calibration bar

Using a lookup table on a greyscale image, we want to provide a bar that shows which colors
represent which intensities, normalized to a range between 0 and 1, in the image.

Open the image A4 Rhod 1.tif and apply the lookup table Rainbow RGB. There are two ways
to achieve our goal. One way is to make a selection in the image and run Plugin>LUT>Add
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Ramp. This will add a ramp with the colors of the lut from the bottom with the value 0 to the
top with the value 255. It only works for 8 bit images.

1 A4 Rhod 1-2.tif
650x515 pixels; 8-hit, 327K

Hlustration 205: A ramp shows
which color represents which
intensity.

The other way is to first calibrate the image intensities using Analyze>Calibrate... A
calibration bar can then be stamped into the image using Analyze>Tools>Calibration Bar...
To calibrate the image you have to enter a number of pairs of uncalibrated and calibrated
values. You can select the form of a curve that will be fitted to the entered data. For a
calibrated image, intensity values will be displayed in the calibrated form, followed by the
greylevel value in brackets. Measurements will be in calibrated form.

Call Analyze>Calibrate... and enter the points 0, 0 and 255, 1. Select the function straight
line. Then use Analyze>Tools>Calibration Bar... stamp the calibration bar into the image.

od 1.tif with bar
3M5

10. Working with multi-dimensional data

In general image data can have multiple dimensions. 3 spacial dimensions, the time dimension
and many channels (for example different wavelengths).
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| 10.1 Time series

Open the image pot.tif. You can play the image sequence using Image>Stacks>Start
Animation. You can use the last button in the ImageJ launcher window to switch the current
tool set to the stack tools. This will display buttons to:

e animate the stack (click again ti stop),

e go to first and last slice,

e go one slice forwards / backwards

e add a slice after the current slice / delete current slice

£ ImageJ (=]

File Edit Image Process Analyze Plugins Window Help

08 =< 4| +x|Ala|e] 2] |w]=]<]> |>]+]-]>]

Hllustration 206: ImageJ with the stack tool set selected.

-

-

As you see the camera position is not exactly the same for each image which makes the plant
somewhat jump around. Use Plugins>Stack Shuffling>Align slices for an automatic stack
registration. Choose either rigid body or translation as transformation.
Make a rectangular selection, so that the black borders that have been created by the stack
registration are outside of the selection and duplicate the stack (ctrl+shift+d).
You can export the series as a movie in one of the following formats:

e animated gif

e avi movie

e quicktime movie
Use File>Save As and one of these formats to export the series as a movie. If your image
sequence is to big to fit into memory at once, you can still create a movie from it by using the
virtual stack opener (File>Import>Virtual Stack).

10.1.1 Measuring velocities

Open the image moving-particles. You see two circles that move from the lower left to the
upper left side of the image. We want to measure the lengths of the paths they traveled.

1 00002+00004(1-17) |- |0EF . Sum-1 (200%) =]

BT, 242197 pixels; 8-hit (imverting LUT); 791 139104 pixels; 32-hit, 56K

il _ I
Hllustration 207: Two moving Hllustration 208: A projection of the
particles. time series.
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In principal this could be done manually using for example the polygon selection tool. Go to
the first slice set the first polygon point to the into the first particle, then go one slice ahead
using the ' key and set the next point and so on. When the path is finished press ctr/+m to

measure its length.

Another possibility is to create a projection of the stack (Image>Stack>Z Project...) and use

the polygon selection tool on it.

The Mtrack? plugin measures the track length automatically. Open it from Plugins>Particle

Analysis>Mtrack?2.

i Object Tracker

Minimum Object Size (pixels): IE—
Maximum Object Size (pixels); |999999

Maximum Velocity: |'15—
Minimum track length (frames) |'1—

[+ Display Path Lengths
v Show Labels

v Show Positions

v Show Paths

OK Cancel

Hlustration 209: The MTrack2

mEX)

1 Paths

2420187 pixels; 8-hit, 46K

}

Hllustration 210: The paths
found by the MTrack?2 plugin.

plugin.
£ Results =[]
File Edit Font
Frame ¥ ¥ [Flagt [0 -
Track Length Distance traveled  Mr of Frames
1 66.94808  47.67599 17
2 109.067215 101.788994 14 -
4 [ o

lllustration 211: The plugin answers the
distance travelled by the particles

(length) and the linear distance from the

start point to the end point of the track.

11. Biological applications

11.1 Colocalization analysis

11.1.1 Visualizing colocalization using overlays

In principle an overlay of the two channels, using two appropriate lookup-tables, like for
example red and green or cyan and magenta, should give as a hint if two fluochromes are in
the same place. In the red/green case places in which the red and green intensities are close to
each other will appear yellow in the image. Another possibility is to use magenta, green and
blue.
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; BEH

c13 14T, 4. 646347 inches (13921 040); 8-hit, 195ME

«| | ]

| |

Hllustration 212: The overlay of the channels. The green
channel has lower intensities and is invisible.

But there are some problems with this approach. Yellow spots will only become visible if the
intensities in both channels are similar, both channels must have similar histograms.
Histogram normalization can be used but may suggest false results since intensities don't
represent the real quantities of molecules anymore.

Open the images coloc-Rhod, coloc-GFP and coloc-Hoechst from the coloc folder. Create an
overlay of the channels that shows the colocalization between gfp and rhodamine.

Instead of an additive overlay of channels the diference can be used. Apply magenta and cyan
lookup tables, convert the images to RGB and calculate the difference using the image
calculator. The same result can be achieved using the Colour merge command from the menu
Plugins>Colour functions. Check Use difference operator in the dialog.

é K

FirstStack: [coloc-example-1tf = |
Firstcolour [Wagenta |
Second Stack: ’W
Second colour m

W Keep source stacks?

% of 2 pre-subtracted from 1? |0

When merging brightfield with fluorescence,
ensure the brightfield image is the first stack

0K Cancel

Hlustration 213: The color
merge dialog.
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i BEH

[»]
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v

Hllustration 214: Overlay of the red and green channel after
histogram normalization.

¢ M=

Histogram of Channel (75¢

_of x|
| —— _:’_“'.

Counl 68040960 Min: 0 Count 2040960 Mim: @
Mean: 4.99 Max 254 Mean: 1.52 Max 255
StoDev: 13 .36 Mode: D (505243 26) StdDev- 4.02 Mode: 0 (53411949)
. Value: &0
List | Copy | Log | List | Copy | Log |
Count: 27
Hlustration 215: The Hlustration 216: The
histogram of the red channel. histogram of the green
channel.
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d mEE] BEH

[ [
0 AEE 0 AEE
Count BE0408E0 Min: 0 Count BE0408E0 Min: 0
Mean: 16.22 MWean 16.73 Max 255
StodDev: 4331 Mode; D (50524326) StoDev: 43 62 Mode: D (53411949)

. Value: 224 . Value: 122
List | Copy | Log | List | Copy | Log |

Count: 39499 Count: 59252

Hllustration 217: The histogram Hllustration 218: The
of the red channel after histogram of the green channel
normalization. after normalization.

; BEH

c13 14T, 4. 646347 inches (13921 040); 8-hit, 195ME

v
13

lllustration 219: Original overlay with auto-display-
adjustment.
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! - |o]x;

4 64x3.47 inches (1392x1040), RGE; 5.5ME

Hllustration 220: Original overlay with auto-display
adjustment in Magenta/Green/Blue.

! - |o]x;

4 64x3.47 inches (1392x1040), RGE; 5.5ME

Hllustration 221: Color merge with difference of the
original channels.
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! - |o]x;

4 64x3.47 inches (1392x1040), RGE; 5.5ME

Hllustration 222: Color merge with difference after
histogram normalization.

11.1.2 Quantification of colocalization

11.1.2.1 Intensity correlation coefficient based methods

In this approach a statistical analysis of the correlation of the intensity values in the two
channels is performed. This is mostly done by using correlation coefficients that measuring
the strength of the linear relationship between two variables, the intensities in the two
channels.

11.1.2.1.1 Pearson's coefficient and scatter plot

A fluorogram or scatter plot can help to judge if colocalization is present or not. In a scatter
plot the x-axis represents the intensity values of the pixels in one channel and the y-axis the
intensities in a second channel. The pixels of the two images will be compared one by one. If
the intensity of pixel (0,0) is 10 in the first image and 15 in the second image, the point 10,15
will be marked in the scatter plot. Sometimes the frequency of the intensity pair is coded by
the color or brightness in the scatter plot. A line will be fitted through the points in the scatter
plot. A positive slope indicates a correlation, a zero slope indicates that the images are
uncorrelated and a negative slope indicates a negative correlation (a mutual exclusion).

The Pearson's Coefficient is a measure of the quality of the linear fit. It is obtained by
dividing the covariance of the two variables by the product of their standard deviations. Mark
that the thickness of the point cloud and the direction of the line have an influence on the PC,
but not the slope of the line. The PC will be near 1 for a positive correlation, near zero in case
of no correclation and near -1 for a negative correlation.
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ne.. [[=|fY

new-2 (200%)|

Bax64 pixels; RGE; 16K

Hllustration 223: lllustration 224:  [llustration 225: A
A noisy image.  Another similar scatter plot of

noisy image. correlated images

ne. = F3

] new-2 (200%)]

B4xE4 pixels; 8-bit; 4k

286

- Cytofluorogram between new-2 an

of 5 i i
0 new-2 255

Hlustration 227: [ustration 228: Illustration 229:
A noisy image. Another similar Scatter plot of

noisy image, uncorrelated images

rotated by 90°.

ne. = B3

] new-2 (200%)]

GB4xE4 pixels; 8-hit; 4K

0 new-2 255

mMM ®=73.1, Y=254.0
Hlustration 231:  [llustration 232 Hlustration 233:
A noisy image.  Another similar ~ Scatter plot of anti-

noisy image, correlated images

rotated by 90°.
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Hllustration 226:
The color overlay
of the input
images.

 col... [ EY

64}(54 pixels; RGE; 16K

Hllustration 230:
The color overlay
of the input
images.

 col... [ EY

64}(54 pixels; RGE; 16K

Hllustration 234:
The color overlay
of the input
images.
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1.0 0.8 _ 0.4 0.0 -0.4 -0.8 -1.0
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0.0 0.0
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¥ ¥

Hllustration 235: Pearson's coefficients for diﬁ”efent scatter plots.

Open the images coloc-GFP and coloc-Hoechst from the folder /2 - coloc. Use the JACoP
plugin to calculate the scatter plot. Run the plugin from the Plugins menu, select the images in
the dialog, select cytofluogram and Add the zero line. The scatter plot will be created and the
fitted line will be shown. The Pearson's Coefficient will be written to the log window as
Correlation Coefficient. If you want to calculate the Pearson's Coefficient without the scatter
plot, check Pearson's coefficient instead of cytofluogram in the dialog.
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i ﬂ BEE i Cytofluorogram between coloc-GFP-1.ti... _ ﬁ
_|ofx

454:3.47 inches (1392 040); RGE; 5.5MB

220

Image A |coloc-GFP-11if
Image B |coloc-Rhod-1.tif «

Correlation-based colocalization:

coloc-Rhod-1 it

[ Pearson's coefficient
[~ Overlap coefficient, k1 & k2

[~ M1 & M2 coefficients
; . 0
[ Costes’ automatic threshold Hllustration 237: The OVWICW

. . 0 - oloc-GFP-1 i 220
[ Van Steensel's CCF ofthe two input images.
shift x | List | Save. Copy...
W Cytofluorogram Hllustration 238: The scatter plot
| Lsica and the fitted line calculated by the
[™ Costes’ randomization JACoP plugm

Object-based colocalization:
[~ Distance based colocalization

[ Spatial Pearson's coefficient

[ Add the zero line

oK Cancel

lllustration 236.: The
dialog of the JACoP
colocalization plugin.

Scatter plot and Pearson's coefficient indicate colocalization, especially when it is complete.
However they rarely discriminate differences between partial colocalization. Mid-range
coefficients between -0.5 and 0.5 do not allow conclusions to be drawn. The result is
dependent on noise and background or the threshold used to supress the background.
Bleadthrough of the fluorescents can lead to false results as well. Finally there could be a non
linear relationship between the two signals, that could not be detected using this method.
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