Image processing and analysis with ImageJ — Solutions - Topic 01 - Installation

Topic 01 - Installation, configuration, help and updates

Solution 1.1: Installation
Go to the Image]J website at http://imagej.nih.gov/ij/.

home | news | docs | download | plugins | resources | list | links

Imaged | |

Image Processing and Analysis in Java

o Features

o News

o Documentation

o Download

o Plugins

o Developer Resources
o Applets/Web Start

o Mailing List

o Links

This page has been visited FIEtIes
times. Send comments to wsr@nih.gov.
Disclaimer

Hllustration 1: The ImageJ website
http://imagej.nih.gov/ij/
Click on Download.

home | news | docs | download | plugins | resources | list | links
Download
Platform Independent
To install Imagel 1.44 on a computer with Java
pre-installed, or to upgrade to the latest full
download iji44.zip (3MB) and extract the Imagel

to the latest pre-release version.

Mac 0S X

(Instructions)

Linux

1.6.0_20 from Sun and the Imagel source code.
(Instructions)

Windows

Windows) or without Java (3MB). (Instructions)

Search

distribution (including macros, plugins and LUTs),

directory. Use the Help>Update ImageJ command to upgrade

Download Imagel 1.44 (5.4MB) as a double-clickahle Mac
0S X application. Includes Imagel64, which uses Java 1.6
in 64-bit mode on Intel Macs running 0S X 10.5 or later.

Download Imaged 1.44 bundled with 32-bit Java (46MB) or
with 64-bit Java (40MB). Both versions include Java

Download Imaged 1.44 bundled with 32-bit Java 1.6.0_20
(28MB), with 64-bit Java 1.6.0_20 (24MB; requires 64-bit

Hllustration 2: The ImageJ download page. Select the
version for your system including the right java

version, 32 or 64 bit.
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System Properties l2|®
.___S_y_g_le_rq_ﬁg_slole_ ) _ Automatic Updates Femate
General | ComputerName | Hardware | Advanced
System:

Micrasoft Windows =P

Prafiessional xE4 Edition
“Wersion 2003
Service Pack 2

Registered ta:
MRI-MET

e S

TEARA-B52-300591 3660067

Camputer:
Intel(R] *<eon(R) CPU
5160 @ 3.00GHz

2.99 GHE 2,00 GE of RaM /

Hllustration 3: The system is 64blt
and has 8GB of memory.

Look at the properties of My Computer in the windows explorer, to find out if your system is 64bit
and how much memory it has. Download the ImageJ version for your system with the appropriate
jJava included (32 or 64bit). Run the setup and answer the questions. At the end ImageJ will be
started for the first time.

Welcome to Image.]

i:) The program will now be auto-configured. You may be prompted ko input the locations of various files that can not be auto-detected. Please consult
the installation instructions For Further assistance.

Hllustration 4: The first time ImageJ is started it auto-configures the thread and
memory settings.

Image.J Configuration rg|

i A configuration file was successfully created as:
; ‘K] iZ:\Program Files\Imagel2iImagel.chg
with the Follawing parameters:
Line 1- .
Line Z- jrelbinijavaw. exe

Lime 3- -2mx640m -cp ij.jar ij. Image]

Please consult the installation instructions For further details,

Hllustration 5: The configuration is
written into the file ImageJ.cfg.

Now the ImageJ-launcher window will be displayed.

= Image.J

File Edit Image Process Anakze Pluginsg Window Help
[=e wE Vs =|
Volker.baecker Faint® ar multi-point selections {right click to switch) 2/13

lllustration 6: The ImageJ launcher window.
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Solution 1.2: Memory-Configuration

Look at the system properties how much memory your machine has, then enter % of it in the
memory options:

& ImageJ % B &
_Fi_lt_a__;_E_d'it - Image  Frocess Anilyze Flugins  window — Help |
| RN otz RoOleess|s]al | =
Falygo Cut Ctrl+3 |
b C O Ctri+C -
Copy to Systemn
Paste Ctri+4

Paste Contraol..,

Clear

Clear Outside

Fill Ctrl+F
Draw Ctrl+D

Invert Ctrl+Shift+1

~ Line Width...
Input/Cutput...
Fonts...
Profile Flot Options...
Arrow Toal...
Paint Tool...
wWand Toaol...
Colors...
Appearance...
Conversions...
[Merriory & Threads...
Froxy Settings...
Compiler...
DICOM..,
Misc. ..

Hllustration 7: Run Edit>Options>Memory & Threads...

® Memory (32-bit) Y|

Maximum memory: (2250  MB
Parallel threads for stacks: 2

“Ikeep multiple undo buffers

¥ Fun garbage collector on status bar click

0K | Cancel| Help|

Hllustration 8: The memory and
threads settings. The machine
has 3GB RAM and two cores.

If for example your machine has 3GB memory, you should enter % * 3000MB = 2250MB.
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The content of the file ImageJ.cfg in the Image] base folder is:

jre\bin\javaw.exe
-Xmx2250m -cp ij.jar ij.Imaged

Solution 1.3: Update

& ImageJ B ®
File Edit Image Process  Analze Plugins  Window H_elp_I

[= IS =P PR NN RN w T e

Irnagel 1.45h / Java 1.6.0_20 (32-hit)

g | 4 | ) | |Imagej website.,..

Image| News...
Cocumnentation...
" Installation...
Mailing List...

Dev, Resources...
Plugins...

Macros...

Macro Functions...
[Update imagel...
Refresh Menus

About Plugins ~ |
About Image)...

Hllustration 9: The Help>Update ImageJ menu.

& Imagel Updater B ® I

Hpiee Topldoaon

You are currently running v1.45h,
If you click "OK", Image] will quit

and you will be running the upgraded
version after you restart Imagel.

IHlustration 10: You can either
choose the current version, an
older version or the daily build.

volker.baecker@mri.cnrs.fr 4/13



mailto:volker.baecker@mri.cnrs.fr

Image processing and analysis with ImageJ — Solutions - Topic 01 - Installation

Image) 1.45h

g is in the public
Hllustration 11: The about-dialog shows the
version information.

Solution 1.4: ImageJ folders

I’J jre {/’ luts
I’J Macros {/” plugins
§ '—'i ii. jar [ Imaged
&o| | Executable Jar Fils |l | Internet Shortout
—! | 1510k | 1B
Imagel.cfg Imagel.exe
CFG File Image] Launcher
1 KB Broken Symmetry Software

[ » README.htrl unins000.dat
e Firefo:x Docurment DAT File
| 3KE 59 KE
_'E unins000.exe

I ‘iﬁ_-' SetupfUninstall

Hllustration 12: The content of the ImageJ
base folder.
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# Mandelbrot.kxt R E®
File Edit Font [ Macros Debug
J/ Mandelbrot set diifun Macra Ctri+R | =
// jerome . mutterer ; Evaluate Line Ctri+y J
Ahort Macro
/f This macro draws Install Macros Ctrl+l im in by

J/ making a selectio Function Finder...  Ctrl+Shift+F he macro,

[ which illustrates £ 1ass arguments
J{ from one macro t Evaluate JavaScript Ctri+) Imacro is

/i benchmarked. -

randelbrot

// Example results, all obtained with || 1.31l and java 1.3.1 jre :
ff Pentium 11-350 Mhz 53.44 secs
[ Pentium I11-500 Mhz 45,09 secs

ff Pentium V-1800 Mhz 11.53 secs
kA GA-400 kb R7 NS sers
| I E|

Hllustration 13: Running a macro from the macro-editor.

Hllustration 14: The result of
running the Mandelbrot-
Macro.

b)
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& ImageJ LXK )

File  Edit Image Process  Anahze _' F"Iugi'ns Window Help

= IS PR AN NG o] T =
Developer Menu Et”[i’:::ts
~ New

Compile and Run...

3D

Analyze

3E'}{am'pies ] -Macros
Filters - -Scripts
Graphics ~ IP Demo
Input-Output = Image Inverter
Lol - Mandelbrot
LoG3D ~ Plasma?2
Macros - Red And Blue
Process .
Segmentation

Stacks

Tools

c) Instead of running the macro, the text file is opened in the macro-editor.

Solution 1.5: Opening images

Hllustration 15: The image A4 dapil tif.

b)
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# Open Folder B ® I

Open all 17 images in "arabidopsis” as a stack?

_IConvert to RGE
_lUse Virtual Stack

Yes Mo | Canceﬂ

lllustration 16: The open folder
dialog.

# arabidopsis % B &
1717 (Potl04Cycle0083); 3524280 pixels; RGE: 6.4ME

4 = -

Hllustration 17: The image-stack created
from the images in the Arabidopsis folder.

# Sequence Options X I

Murnber of images: ﬁﬁ
Starting image: |1
Increment: [1

Scale images: 100 %

or enter pattern:

File name contains:

_IConvert to RGE
W Sort names nurmerically

UlUse virtual stack

352 % 280% 17 (5. 4MB)
Lok | [cancel| | Help|

Hllustration 18: A dialog
that allows to import
image-sequences.
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Wentpellict KLe Lueeine

d) The second time ImageJ adds -1 to the name to avoid confusion. For example opening the
Image A4 dapi 1.tif twice, results in one image with the title A4 dapi 1.tif and another one
with the title A4 dapi 1-1.tif.

e)
[@aresnzen g9
1/2 (Ch2-T1) 146,33x146.33 pum (132011320} 8-bit; 3.3MB
[+
lllustration 19: The image cafe.lsm displayed in
composite-mode.
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# Bio-Formats Import Options 8® I

Stackviewing ————————————  Metadataviewing ———— Information
wiew stack with:  Hyperstack Display metadata Display metadata - Reads mestadata that

may be contained within the file format and
displays it. You can save it as a text file or
Display ROIs copy it from the File and Edit menus specific
to the "Original Metadata" window.
Readability depends upon the manner in
which metadata is formatted in the data
source. The metadata can also be displayed by
10pen files individually Specify range for each series pressing "i* (Image > Show Info) when the
imported image is active.

Stack order: Display OME-XML metadata

Dataset organization —————————  Memory management -

|Group files with similar names Use virtual stack

1Swap dimensions Crop on import

lopen all series

|Concatenate series when compatible Split into separate windows
Color options ———————— Split channels
Color meds; Default Split focal planes

IAutoscale Split timepoints

ok Cancel

lllustration 20: The Bio-Formats Import Options.

Hllustration 21: The image FC green-40X sec.ics

2)
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# Miscellaneous Options G 3

Divide by zero value: |Infinity

IUse pointer cursar
_|Hide "Process Stack? dialog

IRequire control key for shortouts

IMove izolated plugins to Misc, menu

W Run single instance listener

_|Debug mode

OK | Cancel| Help|

Hllustration 22: The misc-options dialog
allows to activate the single-instance-listener.

In windows, select open-with>Choose Program... from the context menu of a tif-file.
Browse to ImagelJ.exe or select ImagelJ Launcher if it appears already in the list. Select
“Always use the selected program...” and press ok.

Solution 1.6: The Image]J website
a)

26.11.7 Unsharp Mask...

M Unsharp Mask.-

Radius (Sigma) 1.0 pixels
Mask Weight {0.1-0.9) 0.60

L Preview

Cancel | 0K )

Sharpens and enhances edges by subtracting a blurred version of the image (the
unsharp mask) from the original.

Unsharp masking subtracts a blurred copy of the image and rescales the image to
obtain the same contrast of large (low-frequency) structures as in the input image.
This is equivalent to adding a high-pass filtered image and thus sharpens the image.

Radius The standard deviation (o blur radius, cf. Gaussian Blur... T) of the Gaussian
blur that is subtracted. Increasing the Gaussian blur radius will increase contrast.

Mask Weight Determines the strength of filtering, whereby MaskWeight = 1 would
be an infinite weight of the high-pass filtered image that is added. Increasing the Mask
Weight value will provide additional edge enhancement.

Hllustration 23: The documentation of the command unsharp
mask.
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Hllustration 24: The image before application of the
unsharp mask filter.

Illustration 25: The image after application of the
unsharp mask filter.

b) Yes, the author's name is Volker Baecker.
¢) Colocalization Analysis, JACOP, ...
d) I find nine plugins that have to do with colocalization:
* (Colocalization
* Colocalization Finder
* RG2B Colocalization
*  JACoP (Just Another Colocalization Plugin)
* FRET and Colocalization Analyzer
* IntraCell
* Find Colocalized Pixels in RGB Channels
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* CDA (Confined Displacement Algorithm for Colocalization)
* Colocalization Colormap

e) It downloads an image cells.tif and counts the number of cells in the image.

File  Edit Font
Slice |Count |[Total Area  |Average Size |Area Fraction |Mean [Mode |IntDen [

cells-1.tf 72 14029241 194.851 12.7 255 255 49586.894
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