Chapter 2

Basic Tools 1

The ImageJ-launcher window consists of three parts. A menu-bar, a toolbar
and a status-bar. You will now get to know the basic tools of ImageJ in more
detail.

2.1 Pixel information, zooming and scrolling
Open the image A4 dapi 1.tif from the folder 01 - opening images.

e Note that some information about the image is displayed at the top of the
image-window. The size of the image in pixel, the type and the size of the
image in the memory of the computer.

e Select the magnifying glass tool on the toolbar and click into the image.
A left-click does a zoom-in, a right-click a zoom-out. You can use the “4”
and “-” keys on the keyboard to do the zooming.

e Note the position-indicator in the upper-left corner, when the image is
bigger than the window.

e Zoom-in so that the position-indicator appears. Select the scrolling-tool
on the toolbar. Click in the image and without releasing the button move
the mouse. Go to the lower-right corner of the image.

e Select the magnifying glass tool again. Zoom-in so that the position-
indicator appears. You can drag the image by holding down the space-bar
instead of using the scrolling-tool. The advantage is that another tool can
be active in the same time. Try to scroll to the lower left corner.

e Zoom in to the maximum zoom and move the mouse over the image. Look
at the status-bar of the ImageJ-launcher window. The position of the pixel
under the mouse-pointer and its grey-value are displayed.
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a) What is the maximal possible zoom? What is the minimal zoom?

b) What is the grey-value of the pixel with the coordinates x=549 and y=3057
What is the grey-value of the pixel with the coordinates x=>58 and y=2467

¢) What is the width and height of the image? What is its type? What is
its size in the memory?

d) Move the mouse over the image. In which direction does the x-coordinates
of the pixels become bigger. In which direction does the y-coordinates
become bigger? How does the coordinate-system look like?

e) You can change the orientation of the y-axis. Open the dialog Analyse>Set
Measurements... and select Invert Y coordinates. Move the mouse
over the image again. How did the coordinate-system change?

2.2 Area selection tools

Make sure that the rectangular selection tool is active. You can now make a
rectangular selection in the image by clicking at a point and dragging the mouse.
While doing this the width and the height of the selection are displayed. Once
you release the mouse button you made a selection on the image. You can still
change its position by clicking into it and dragging and its size by using the
handles.
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2.2. AREA SELECTION TOOLS

2)

Make a rectangular selection on the image. Move it around. Change its
size. Find out in the ImageJ documentation (ImageJ User Guide) which
modifier keys exist for the rectangular selection tool and what they do.
Try them.

Note that you can create complex selections by using the shift and the
alt key. Shift adds to a selection, alt removes from a selection. Try it.
Move the complex selection around. Note that you create one selection,
even if the parts may be separated.

Change the selection color to magenta (Edit>Options>Colors. . .).

Right-click on the rectangular-selection tool-button and select the rounded-
rectangle-tool. Make a selection. You can change its color and style by
double-clicking on the tool-button.

Double-click on the rounded-rectangle-tool-button. Change the value of
the corner-arc size and draw a new selection.

Try the other area-selection tools up to and including the freehand-selection
tool. Note that when using the freehand-selection tool you should not try
to close it yourself. Just go near to the beginning and release the mouse
button. The selection will be closed automatically.

Make a selection and run the command Image>Crop. What happens?

You can reload the original image using File>Revert (ctrl+r). Make a
selection again and run the command Image>Duplicate (shift+d). What
happens?
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2.3 Measuring and the results table

The command Analyze>Measure (m) measures either properties of the whole
image or of the selection on the image, if there is one. With the dialog under
Analyze>Set Measurements you can choose which properties will be measured.
Measurements are written into the global results table.

a)

Use the freehand-selection to select a nucleus, then measure its area and
mean gray-value. Do the same thing for multiple nuclei. Zoom into the
image to make a precise selection.

Call File>Duplicate from the results table to make a copy of the results.
Measure a new selection. To which table is it added?

Use File>Rename and rename the original results table (Results) to
“old”. Make a new measure. Into which results table is it added?

Clear the results table using Results>Clear Results and measure at
least 3 nuclei again. What is the mean, the standard-deviation, the
min, the max and the mode of the distribution of the area-values? Use
Results>Summarize and Results>Distribution... to get the answers.

2.4 Line selection tools

Try the line selection tools straight-line, segmented-line and freehand-line. Note
that while creating the line for the straight-line and segmented-line the length
of the current segment and the angle with the x-axis are displayed in the status-

bar.

a)

b)

Use the straight-line tool to estimate the distances between the centers of
the nuclei.

Use the straight-line tool to estimate the diameters of the nuclei.

¢) Use the segmented line tool to estimate the perimeters of the nuclei.
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2.5. PROFILE PLOTS

d) Use the freehand-line tool to estimate the perimeters of the nuclei.

e) Use the angle tool to estimate the angles between three nuclei.

2.5 Profile plots

You can use the line selection tools to create profile plots. A profile plot contains
the intensity values along the line. First make a line selection across a nucleus,
then press the key k (the shortcut for Analyze->Plot profile). Note that,
when the line width is bigger than one, the profile will be averaged over the
width. You can change the line-width by double-clicking on the line-selection
tool-button.

a) Use a profile plot to estimate the diameter of a nucleus. Note that the plot
is an image itself so that you can use ImageJ tools on the plot. Is there
an advantage of using the profile plot rather than measuring the diameter
in the original image?

b) Create a profile plot across a nucleus. Without changing the selection,
change the line-width and create a new plot. What has changed?

c¢) Create a profile plot across a nucleus, then make the line longer and create
another profile plot (The easiest way to do this without changing the
direction is using a horizontal or vertical line with shift pressed.). What
is the difference between the plots? Measure the distances between the
same two interesting points in the two plots. Do you get the same result in
the two plots? How is this possible? - Hint: Look at the pixel width and
height in the properties of the two plot images (Image>Properties...).
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d) Create a profile plot across a nucleus. Click the List button on the profile
window. Copy the values into the clipboard (ctrl+a to select all and
ctrl+c to copy). Open the Curve Fitter from Analyze>Tools>Curve

Fitting. ... Delete the values in the curve fitter and paste the values from
the clipboard into it (ctrl+v). Make a gaussian-fit of the measurement-
points.

2.6 Point selections

You can use the point selection tools to manually count objects in an image.
With the point selection tool use shift to add points or use the Multi-point
tool. You can delete points using alt.

a) Make a point selection on three nuclei, then make a point somewhere
in the background and make point selections on the remaining nuclei.
Delete the point on the background using alt-click. What happens to the
numeration of the points?

b) Save an image with a point selection somewhere in the format tif (File>Save
As>Tiff...). Close the image and reload the saved image (File>Open. . .).
What happened to the selection? Can you still modify it?

¢) Check the option Auto-Measure of the point tool. What does it do? Hint:
Look at the results table.

d) Can you use the point-selection tool with the Auto-Measure and Auto-Next
Slice options to trace the yellow particle in the time series image moving-particles.tif
from the folder 02 - basic tools?
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2.7. THRESHOLDING AND THE MAGIC WAND TOOL

2.7 Thresholding and the magic wand tool

The magic wand tool allows to make a selection of connected pixels in an im-
age. There are two different ways to determine which pixels. Either the tool
selects all connected pixels with the same intensity value (eventually plus-minus
a given tolerance) or it selects all thresholded pixels that are connected, i.e. all
pixels with intensities bigger than a given minimum and smaller than a given
maximum. The minimum (and maximum) threshold values can be set using the
threshold-adjuster. You can open it from Image>Adjust>Threshold (shift+t).
Switch the display-mode from Red to Over/Under and select Dark background.

Every click with the wand-tool creates a selection. If you want to remove
the selection from an image use ctrl+shift+a.

a) Use the wand-tool in combination with the threshold adjuster to select
nuclei. Measure the nuclei. How long are the biggest and the smallest
perimeters and how long are the biggest and smallest diameters?

b) Use the wand-tools to select all nuclei as one selection (shift-click).
Find out what percentage of the image area is covered by nuclei. Hint
you can use ctrl+a to select the whole image.

2.8 The roi-manager

The roi-manager is a tool that helps to work with selections. You can keep an
unlimited number of selections and display, modify and measure them whenever
you want. Commands from the roi-manager always work either on the selected
rois or on all rois in the manager if none of them is selected.

a) Use the wand-tool to select a nucleus, then press ’t’ (shortcut for add
to roi-manager, you find the roi-manager under Analyze>Tools>R0OI
Manager....). Select the Show All option on the roi-manager. Select
the other nuclei and them to the roi-manager.

b) Click on one of the labels (for example 5) in the image. Note that the
corresponding line in the roi-manager is selected. Modify the selection
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(remove a part using the frechand-selection tool with alt pressed). Press
the update button in the roi-manager to make the change permanent.

Select one or multiple lines in the roi-manager (you can use ctrl/shift)
and press the measure-button. Press the deselect-button, close or clear
the results-table and press the measure-button again.

What does the flatten button do? Hint Have a look at the image type
of the resulting image.

Set the lower threshold so that the background becomes blue and there
are no holes in the nuclei. You can create a selection from the thresholded
values by using Edit>Selection>Create Selection. Add the roi to the
roi-manager and run the split command. What happens?

Add the selections of all nuclei to the roi-manager. Now open the image A4
Rhod 1.tif from the folder 02 - basic tools. With the newly loaded
image active, deselect Show All from the roi-manager and select it again.
Press the measure button. What happens?

2.9 DMeasuring objects with the Particle Ana-

lyzer

Until now all selections have been created individually. The particle-analyzer
allows to automatically create a selection for each object (particle) in the image,
i.e for each connected region of pixels above the minimum threshold and below
the maximum threshold.
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2.10. ARROWS, ANNOTATIONS AND OVERLAYS

a) Use the threshold-adjuster (Image>Adjust>Threshold or shift+t) and
the particle-analyzer to add the nuclei to the roi-manager (deselect every-
thing on the particle-analyzer except Add to Manager).

b) Delete all from the roi-manager and use the particle-analyzer again. This
time select the Exclude on edges option. Can you explain what this
option is good for and when it should be used?

¢) Use the particle-analyzer again. This time try to exclude objects that
are too small to be nuclei by setting a minimum size in the dialog of the
particle-analyzer.

d) Use the particle-analyzer to select only nuclei that have a high circularity
value. What is the value that excludes the two nuclei with the lowest
circularity?

e) Open the image inclusion.tif. Imagine that the inner and the outer
white rectangles are particles. Use the particle-analyzer with and without
the Include holes option. For this comparison deselect Add to Manager
and select Display results. What is the difference?

f) Use the particle-analyzer to find out how many bright blobs there are in
the image blobs.gif from the folder 02 - basic tools. What is the
average area of the blobs?

2.10 Arrows, annotations and overlays
Images can be annotated in a non-destructive way, using overlays. Arrows and

other selection can be added to the overlay by pressing b (Image>0verlay>Add
Selection).
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2)

Use the arrow tool (right-click on the line-selection tool-button) to create
to arrows that point to a nucleus each. Before creating the arrows, use
the options of the arrow-tool to set the color of the arrows to magenta.

Use the text tool to write an annotation for each arrow (nucleus one
and nucleus two). Use ctrl+b to add the text to the overlay as it is
or ctrl+alt+b to it to the overlay with different options.

Modify the arrows. Hint: Call Use Image>0verlay>To ROI Manager first.
Don’t forget to click the Update-button on the roi-manager after modifying
an arrow.

Replace the text nucleus one by another text (first nucleus). Hint: - You
can not modify the text itself. Select the text in the roi-manager, write a
new text with the text-tool and press the update-button.

Add a third annotation. Hint: Convert the selections back into an overlay,
add the new annotation to the overlay.

Use Image>0verlay>Flatten (ctrl+shift+f) to create an image con-
taining the annotations that you can copy into your presentation. In this
image the annotation is not an overlay or roi, but added by changing pixel
values.
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