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Abstract

The  MRI  Grid  is  a  tool  in  MRI  Cell  Image 
Analyzer,  that  can  be  used  to  associate 
measurements with labeled positions on a board.

Illustration 1: The interface that  
allows to define grids.

The  user  can  define  a  grid  with  an  arbitrary 
number of rows and columns. The positions on 
the grid can be labeled. A grid can be overlayed 
to  an image and the positions  of the rows and 
columns  can  be  changed.  A  results  table  of 
measurements  can  be  modified  to  include  the 
label  of  the  nearest  grid  point  for  each 
measurement.

The  measurements  can  be  sorted  by  image 
coordinates,  by labels  or by grid positions.  For 
each empty positions a row containing only the 
corresponding label can be added.

Illustration 2: A grid on a binary image.

Illustration 3: A results table with positions 
on the grid (A1, A2, ...) and measurements.
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Quick start

Opening the grid tool

Illustration 4: The grid tool is started from the toolset 
MRI Tools.

To use the grid tool you need  ImageJ1 together 
with  the  MRI  plugins2.  Select  the  toolset  MRI 
Tools.  Click on the grid button   to open the 
MRI Grid tool.

Creating a new grid

Illustration 5: The 
MRI grid tool.

1 http://rsb.info.nih.gov/ij/  
2 http://www.mri.cnrs.fr/mriwiki/index.php?  

pagename=ImageJ%20plugins%20from
%20Montpellier%20RIO%20Imaging

Illustration 6: A grid on a binary 
image.

Open an image using ImageJ. Enter the number 
of rows and columns on the grid tool and press 
new. The grid will appear on the active image.

Adjusting the grid

When the mouse-pointer is over a grid-line, the 
cursor changes. Left-click and move the mouse, 
to move a vertical  line to the left or right or a 
horizontal line up or down. 

Illustration 7: The grid has been 
adjusted.

By  grabbing  a  vertical  or  horizontal  line  and 
pressing  the  ctrl-key  you  can  move  the  whole 
grid. (Remark that this way you can move lines 
out off the image. If this should happen move the 
whole  grid  back,  move  the  line  at  the  border 
closer to the inner lines and move the whole grid 
again.)
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A line can be moved until it touches its neighbor. 
The order of lines cannot be changed.

Defining Labels

Press the edit names button. A table representing 
the grid positions and the corresponding labels is 
opened. By default the labels correspond to row 
and column indices.

Illustration 8: The default labels.

Edit  the  names  according  to  the  schema  you 
want. Cells with empty labels will be ignored.

Illustration 9: Customized labels.

Saving the grid

Select the  Save...  command from the  File menu 
of the MRI Grid. In the dialog enter the name of 
the  grid.  The  grid  will  be  saved to  the  _grids 
folder in the ImageJ installation directory. It will 
appear in the list of the MRI Grid interface. 

Illustration 10: Saving a grid...

Illustration 11: The user  
enters a name.

Use the Save As... command to save the grid in a 
folder different from the _grids folder

Loading an existing grid

You can open a grid by double-clicking on the 
name in the list.  The name of the opened grid 
will become green until changes to the grid are 
made.
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Illustration 12: A grid can 
be loaded from the list.

Use the Open... command to load a grid that has 
been saved in a folder different from the  _grids 
folder.

Transferring the grid to another image

The  active  grid  is  either  the  last  loaded  grid 
(shown in green in the list) or the grid that is set 
on the last active image. To set a modified grid 
to a new image remove the grid from the target 
image if there is one, select the image with the 
source grid, select the target image and press the 
set button.

Removing a grid from an image

Select the image and press the remove button on 
the MRI Grid tool.

Deleting a grid

To delete a grid from the list and from the _grids 
folder, select it in the list, right-click on the list 
to  bring  up  the  context  menu  and  select  the 
command delete selected.

Illustration 13: Deleting the selected 
grid.

Adding labels to a results table

Illustration 14: A result table 
containing labels indicating the 

positions of measurements.

Use the Particle Analyzer to measure objects in a 
binary  image  as  usual.  Make  sure  that  the 
centroids are  measured.  Click the  apply button 
on  the  MRI Grid tool.  A second  results  table, 
containing  the  results  together  with  the  labels 
from the grid will be opened.
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Options

Sort by coordinates
The order of the original results table is kept. 
The results are sorted by the y-coordinate and the 
x-coordinate of the upper left corner of the 
objects' bounding boxes. 

Sort by label
The results are sorted by labels in 
alphanumerical order (A1, A2, A3, A4, AA1, ...).

Sort by grid position
The results are sorted by the position on the grid 
from left to right and top to bottom.

Add empty
Normally empty positions, i.e. positions on the 
grid without an object, do not appear in the 
results table. This can make comparisons more 
complicated. If you select add empty, a row 
containing the label and a zero for each 
measurement is added for each empty position.

Color
Click the color button to change the color of the 
grid. Changing the color might be helpful in case 
the current grid color has not enough contrast 
with the colors in your image.

Example application

Introduction

Arabidopsis plants are grown on fixed positions 
on  a  board.  Plants  on  the  board  are  grouped 
according  to  different  experimental  conditions. 
At different time points photos are taken. With 
help  of  image  analysis  the  growth  of  the  leaf 
surface of the plants  shall  be measured for the 
different conditions.

Alignment of images

Each  series  of  images,  representing  the  same 
board at different time points, should be stored in 
one folder and the images should be numbered 
according to their age. 

Select the Montpellier RIO Imaging toolset.

Illustration 15: Selecting the Montpellier RIO Imaging 
toolset.

Click  on  the   button  to  open  the  visual  
scripting  launcher.  From  the  visual  scripting  
launcher open  the  application  register  series 
from  the  menu 
Applications>applications>stacks.

Illustration 16: The "register series"  
visual scripting application.
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Click  on  the  register  series button.  This  will 
open the  list editor. Click on the  add  button. A 
file dialog will be opened. Set the field file types 
to  all images. Select all folders containing your 
images and click the open button. The names of 
the images should now appear in the list editor.

Illustration 17: Images of the board taken at  
different time points.

Illustration 18: The list editor allows to run applications 
on a set of images.

Illustration 20: Images from different folder have added to 
the list.

If the order of the images is not correct, select all 
images  and  remove  them  using  the  button 
remove  selected.  Then  use  the  add  button 
multiple times to add the images folder by folder, 
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by  selecting  all  images  in  a  folder  in  the  file 
dialog.

When you press the close button the application 
will  start  to  work.  A  sub  folder  aligned, 
containing the aligned images, will be created in 
each  image  folder.  The  calculation  of  the 
alignments can take a long time.

Rotating the image

Open an image from the  aligned sub folder.  If 
the  edges  of  the  board  are  not  parallel  to  the 
edges  of  the  window  you  should  rotate  the 
image.  Use the  angle tool  from the  ImageJ 
launcher window to measure the angle. Open the 
rotate  dialog from  the  menu 
Image>Rotate>Arbitrarily.  Enter  the  measured 
angle multiplied by -1 and click ok.

Setting the scale

Per  default,  measurements  are  made  in  pixels. 
You can set a scale so that your measurements 
will be made in a given unit like for example cm. 

Open  an  image  from  the  aligned sub  folder. 
Make a  line selection of a known distance,  for 
example the long side of the board, using the line 
selection tool from ImageJ. 

Illustration 21: A known distance has 
been selected in the image.

Illustration 22: Setting the 
scale from a known distance.

Open  the  Set  Scale dialog  from  the  Analyze 
menu.  In  the  field  known  distance enter  the 
length of the board in cm. Change the unit to cm 
in  the  unit  of  length field.  If  you  click  ok the 
scale will be set for the active image. Check the 
Global checkbox if  you  want  to  use this  scale 
with all images. 

Segmentation of the plants

Open  the  Threshold  Colour dialog  from  the 
menu  Plugins>Segmentation. Switch to the  Cie 
Lab color  space.  In  the  green/red  component 
adjust the maximum until the first part of a plant 
disappears. Move the maximum just before that 
point.  Close  the  Threshold  Color dialog. 
Transform  the  image  into  a  grey-scale  image 
with the Image>Type>8-bit command. Open the 
Threshold dialog (shift-t) and set the minimum to 
0  and  the  maximum  to  254.  Press  the  apply 
button. You now have a binary image. 
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Illustration 23: The Threshold 
Color tool.

Select the startup macros toolset. Use the Pencil  
Tool and  the  Paintbrush  Tool to  cleanup  the 
image. To draw or paint in white or black, use 
the  color  picker to  select  white  or  black  as 
foreground color.

Illustration 24: Objects that are more or less 
green have been segmented.

Remove  all  objects  that  are  not  plants 
(Alternatively you can remove the objects before 
changing the image type to grey-scale). Separate 

plants  touching  each  other,  by  drawing  a  thin 
white line. By double-clicking on the  Pencil- or 
Paintbrush-tool you can open a dialog, in which 
you can set the width of the tool. If parts of a 
plant are not connected with the main part, draw 
a small connection in black. 

Illustration 25: Manual correction have  
been made to the segmentation.

Using the grid

You  can  either  use  the  whole  stack  of  input 
images or the stack of masks or a z-projection of 
one of these, to define the grid for one series. In 
this example a z-projection of the masks is used. 
Import  the  mask  images  using 
File>Import>Image Sequence and create the  z-
projection from Image>Stacks>Z Project...

Illustration 26: A z-projection of a series of masks can 
be used to adjust the grid.
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Open the  MRI Grid tool. To define a new grid, 
enter the number of rows and columns and press 
the  new button.  Click the  edit  names button to 
change  the  labels.  Positions  with  empty  labels 
will be ignored.

Alternatively  open  an  existing  grid  by  double-
clicking on its name in the list and set it to the 
image, by clicking on the set button. 

Adjust the rows and columns in a way that they 
best fit the rows and columns of plants.

Now open one mask image after  the other and 
execute the following steps.

Make  sure  that,  in  the  Analyze>Set  
Measurements dialog, at least area and centroid 
are  selected.   Run  the  Particle  Analyzer from 
Analyze>Analyze  Particles.  Enter  a  minimum 
size,  that  is just  above the area of the smallest 
plant in the image,  to remove remaining noise. 
Click the  apply button on the  MRI Grid dialog. 
Copy the results from the new results table and 
paste them into a spreadsheet file.

Illustration 27: 
Pressing apply on 
the MRI Grid tool  

adds the labels to the 
results table.

Illustration 28: Labels 
indicating the position of  

the object have been added 
to the results table.
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