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Les étapes du traitement de 
l’analyse d’image 

Prétraitement  niveaux de gris 
 

Segmentation  image binaire 
 

Post-traitement  régions d’intérêts 
 

Quantification  données 
 

La capture  image brute 

Amélioration 
 

Publication 
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Le traitement et l’analyse d’images 
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ImageJ est un logiciel libre de traitement 
et d’analyse d’images 

Traduction en Java du logiciel NIH Image 
du National Institutes of Health (USA)  

développé par Wayne Rasband 
 

Il fonctionne sur de multiples plates-formes (Windows, Mac, Linux, Unix, …). 
 

http://rsbweb.nih.gov/ij/ 
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Installation  
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Installation 
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Configuration 
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Configuration 

Edit → Option → Memory & Treads... 
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Mise à jour 

Help→ Update ImageJ... 
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Installation de Plugins 

Help→ Plugins... 

- Recherche des plugins  
Sur internet 
Help-->Plugins... 
  
- Glisser-Déposer  
les fichiers .class ou .jar 
sur la fenêtre ImageJ 
 
- Choisir l'emplacement  
dans le répertoire Plugins 
 
- Mettre à jour les menus 
Help--> Refresh Menus 
 
- Apparition de la  
nouvelle commande 
dans le menu Plugins 
  

Help→ Refresh Menus 
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Dossiers ImageJ 
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1 
Topic 01 - Installation, configuration, 

help and updates 
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Les bases pour l'utilisation d'ImageJ 
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Interface 

Barre de menu 

Barre d'outils 

Barre d'état 
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Ouvrir une image 
File → Open... 

Drag and Drop sur la fenêtre 
ou l’icône  

File → Open ... 
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Informations pixel 

Curseur de souris 

Informations sur le pixel  
sous le curseur de la souris 
position en x,y 
et valeur en niveau de gris 

Informations image 
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Zoom 
Touche « - » 

Touche « + » 

Déplacement de l'image dans la fenêtre 
Avec la souris et la barre d'espace appuyée 

Zone affichée  
Rapport affichage/image 
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Outils de sélection (ROI) 

Ovale 
Polygone 

À main levée 
Rectangl
e 

Ligne 
Angle 

Point 
Baguette 

Choix d'outils différents : Clic droit sur triangle rouge 

Options : Double clic sur l'icône de l'outil 

Ajouter à la sélection : Maj-clic 

Supprimer de la sélection : Alt-clic 

Retrouver la sélection :  Edit → Selection → Restore Selection 
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ROI Manager 

Analyse → Tools → ROI Manager... 
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Outil Point pour le comptage 
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Dessin 

Clear → Noyau 

Fill → Nucléole 
Draw → Cellule 

Edit → Clear... 
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Annotations 

Analyse→Tools→Scale Bar... 
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Histogramme 

Analyse→Histogram 
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Seuillage 

Image→Adjust→Threshold... 
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Plot Profile 

Analyse→Plot Profile 
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Mesures de sélection 

Analyse→Measure 
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Mesures d'objets 

Analyse→Analyse Particles... 
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Macro 

Plugins→Macros→Run 
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Enregistrement de macro 

→ 

Plugins→Macros→Record... 
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Plugins 

Stack 

Plugins→3D→3D Viewer 
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Barres d'outils 
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Panneaux de commandes 

Plugins→Utilities→Control Panel 
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Topic 02 – Basic tools 1 
 

Topic 03 – Basic tools 2 
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L’image numérique 
 
Les Prétraitements  
 
La Segmentation 
 
Les Post-traitements  
 
La Quantification 
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Image et perception 



Volker BAECKER - Marc LARTAUD 

Image et déformations 

Bruit PSF 
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Résolutions : Nombre de pixels par pouce à l'affichage 

Ecran 72 dpi 

Impression 300 dpi 
1024*1024 

1 Mega pixels 
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y 
x 

Codage binaire 
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y 
x 

3bits8 valeurs 5bits32 valeurs 1bit2 valeurs 
Codage 
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y 
x 

Codage 8 bits 0255  Valeurs de Niveaux de gris 
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y 
x 

Codage couleur 24 bits RVB 
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Piles d’images : Stack 
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Format d'image 

RAW : image brute 
TIFF : sans perte + metadonnées 
JPEG : compression avec perte d'information 
LSM : format propriétaire de chez Zeiss 
OME-TIFF : format Open Microscopy Environment 

Format de fichier 

8bit [0,255]  
16bit [0,65 535],  
32bit [-3.4*10^38 , +3.4*10^38]  
8bit color (LUT) 
RGB 24bit [(0.0.0),(255.255.)] 
Stack 
HyperStack 
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Topic 04 – What is a digital image? 
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L’image numérique 
 
Les Prétraitements  
 
 
La Segmentation 
 
Les Post-traitements  
 
 La Quantification 

Amélioration de la visualisation 
Filtres et opérations 
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Histogramme  
Dynamique = [ valeur_mini , valeur_maxi ] 
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Corrections linéaires 

Luminosité Contraste  

Niveaux   

Luminosité  
Contraste 

Mini  
Maxi 

Image→Adjust→Brightness/Contrast... 
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Correction non linéaire : Egalisation de l’histogramme 
Densité de probabilité normalisée pour aplatir l’histogramme 

Process→Enhance Contrast 
Normalisation  Egalisation 
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Correction non linéaire du Gamma 
y = range * (x / range ) ^ gamma 
range = gamme de valeurs des pixels de l'image  
  
 

Process→Math→Gamma... 
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LUT : Lookup Unit Table 

Image→Lookup Table 
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Réglages avec la LUT Hi Lo 



Volker BAECKER - Marc LARTAUD 

Réglages avec la LUT Hi Lo 
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Outils LUT dans ImageJ 
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Réglages d'images composites 

Image→Color→Make Composite 
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Topic 05 – Brightness and Contrast 
Adjustment 
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L’image numérique 
 
Les Prétraitements  
 
 
La Segmentation 
 
Les Post-traitements  
 
 La Quantification 

Amélioration de la visualisation 
Filtres et opérations 
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Filtres de convolution 

Image source 

Noyau  

Image résultante 

Produits du noyau 
et de la source 

Le pixel cible prend la valeur de la somme des produits normalisée 

1600/12=133 

  ∑=12 

  ∑=1600 
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Image source Noyau Image résultante 

Filtres de convolution 
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Image source Noyau Image résultante 

Filtres de convolution 
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Image source Noyau Image résultante 

Filtres de convolution 
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Image source Noyau Image résultante 

Filtres de convolution 
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Image source Noyau Image résultante 

Filtres de convolution 
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Image source Noyau Image résultante 

Filtres de convolution 
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Image source Noyau Image résultante 

Filtres de convolution 
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Image source Noyau Image résultante 

Filtres de convolution 
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Image source Noyau Image résultante 

Filtres de convolution 



Volker BAECKER - Marc LARTAUD 

Image source Noyau Image résultante 

Filtres de convolution 
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Image source Noyau Image résultante 

Filtres de convolution 
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Filtre 
passe-bas  
moyenneur 

Process→Filters→Convolve... 
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Filtre  
Gaussien 

Process→Filters→Gaussian Blur... 
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Le résultat est une accentuation des détails et du contraste  
mais aussi une augmentation du bruit 

Filtres Passe-haut 
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Filtre Détection de bords 

Process→Finds Edges 

Les images sont convoluées  
par les filtres de Sobel 
Le résultat est la racine carrée  
de la somme des carrés des images  
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Un filtre médian affecte au pixel central la 
valeur médiane de la série : 

La valeur médiane de : 12,13,14,15,18,19,21,27,29 est 18. 
 
Filtre min → 12 
Filtre max → 27 
 
 

Filtre non linéaire : le filtre médian 
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Filtre  
médian 

Process→Filters→Median... 
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Combinaison Gaussien Laplacien 
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Filtres et Opérations dans ImageJ 



Volker BAECKER - Marc LARTAUD 

6 

Topic 06 – Noise and filter 



Volker BAECKER - Marc LARTAUD 

Correction du fond 
Sources de dégradation 
- Bruits de la caméra: bruit aléatoire, «pixels chauds» ,bruits périodiques  
- Illumination non-homogène  

Correction à la capture 
Fixer les réglages microscope – acquisition 
Captures moyennées  d’un champs noir CN (en coupant le trajet optique) 
d’un champs clair CC (lame sans échantillon) et de l’échantillon  
Image corrigée = ( (échantillon - CN) / (CC - CN) ) * 255   
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Correction du fond 

Correction après la capture 
Bruit aléatoire : filtre gaussien ou médian mais perte de détail 
 
Pixels chauds : filtrer les pixels saturés isolés  
 
Bruit périodique : filtre de Fourier 
 
Illumination non-homogène :  
- Soustraire la même image très floue (filtre gaussien très large) 
- Algorithme « rolling ball » (ImageJ ProcessSubstract Background) 
- Toute une serie de plugins implémentés dans ImageJ (Fitting a polynomial surface) 
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Masquer le  fond 
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Masque de Flou 
1 1 1 
1 1 1 
1 1 1 

Flou - Orig 

Orig –(Flou – Orig) 
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Topic 07 – Background correction 
Unsharp masking 
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L’image numérique 
 
Les Prétraitements  
 
La Segmentation 
 
Les Post-traitements  
 
 La Quantification 

Permet de séparer les 
régions d'intérêt du fond.  
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Le Seuillage automatique 

Image→Adjust→Threshold... 
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Le Seuillage automatique 

Image→Adjust→Threshold... 
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Le Seuillage automatique 

Image→Adjust→Threshold... 
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Le Seuillage manuel 
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Le Seuillage automatique 

Image→Adjust→AutoThreshold... 
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Seuillage local automatique 
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Plugin k-mean clustering 



Volker BAECKER - Marc LARTAUD 

Filtrage avant le seuillage 
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FFT filtres dans le domaine de Fourier 
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Couleur et 
segmentation 
séparation RGB 

Image→Color→Split Channels... 
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la Teinte ou Hue se référant à la couleur 
codée de 0 à 6 correspond à une distribution cyclique des couleurs 
le noir, le blanc et les nuances de gris sont codés à 0, comme le rouge 

la Saturation : mesure de l'absence de blanc dans une couleur 
le " rouge pompier " étant une couleur saturée et le rose une couleur non saturée 

l'Intensité ou Luminance : mesure de l'intensité d'une couleur, distinction entre clair et 
foncé 

Décomposition HSI 
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Couleur et segmentation 
séparation HSI 

Image→Type→HSB Stack... 
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Seuillage couleur 

Image→Adjust→Color Threshold.. 
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Plugin Colour Deconvolution 



Volker BAECKER - Marc LARTAUD 

8
1 

Topic 08 – Segmentation 
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L’image numérique 
 
Les Prétraitements  
 
La Segmentation 
 
Les Post-traitements  
 
 La Quantification 

Transformations de 
morphologie 
mathématique 
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Principe 
Elément structurant 

On déplace l’élément 
structurant sur toute 
l’image  
Le pixel sera noir si:  
l’élément structurant est 
inclus dans un objet de 
l’image  
EROSION 
 
l’élément structurant 
touche un objet de l’image 
 DILATATION 
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Morpho_math 
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Morpho_math 
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Menu Binary 

Process→Binary→Options 
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Erodé Ultime 

L’érodé ultime : la dernière fraction de l ’objet restant avant sa 
disparition lors d’érosions répétées. 

Process→Binary→Ultimate Points 
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La ligne de partage des eaux : watershed 

Cette transformation morphologique est la principale méthode de 
segmentation d'images proposées par la morphologie 
mathématique.  

Process→Binary→Watershed 
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Opérations logiques 

Process→Image Calculator... 
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Construction d’une fonction contour 

Erosion 1 XOR 

Contour 



Volker BAECKER - Marc LARTAUD 

Morpho_math en niveaux de gris 

Erosion 
agrandit les zones 
sombres 

Dilatation 
agrandit les zones 
claires 

Plugin 
Grayscale Morphology 

Plugins→Morphology→Gray Morphology 
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Morpho_math en niveaux de gris 

Ouverture 
Erosion puis  
Dilatation 
supprime les petites 
zones claires 

Fermeture 
Dilatation puis  
Erosion 
supprime les petites  
zones sombres  
 
  Plugins→Morphology→Gray Morphology 
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Exemple  

Colour Deconvolution 

Seuillage 
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Exemple 

Analyse particules → ROI Manager 
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Exemple 

Boucher les trous 

Inversion 

Carte des distances 
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Exemple 

Mesures des moyennes de niveaus de gris 
sur la carte des distances → 
Estimation de la position des grains d'amidon  
dans la cellule 
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Topic 09 – Matematical Morphology 
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L’image numérique 
 
Les Prétraitements  
 
La Segmentation 
 
Les Post-traitements  
 
 La Quantification 
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Mesures  
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Mesures 

- Longueur 
- Surface 
- Périmètre 
- Moyenne des valeurs de niveaux de gris 
- Niveau de gris le plus fréquent (sommet de l’histogramme) 
- Min et Max des niveaux de gris 
- Centroid : moyenne des x,y 
- Center off mass : moyenne des x,y pondérée par les intensités 
de niveaux de gris  
- Circularité : 4pi(surface /périmètre²) = 1 pour un cercle 
- Etc ... 
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Topic 10 – Quantification 


