Image processing and analysis with ImageJ — Solutions - Topic 01 - Installation

Topic 01 - Installation, configuration, help and updates

Solution 1.1: Installation

Go to the Image]J website at http://imagej.nih.gov/ij/.

home | news | docs | download | plugins | resources | list | links

ImﬂgEJ ‘ | | search

Image Processing and Analysis in Java

o Features

o News

o Documentation

o Download

o Plugins

o Developer Resources
o Applets/Web Start

o Mailing List

o Links

This page has been visited [FIem3mE
times. Send comments to wsr@nih.gov.
Disclaimer

Figure 1: The ImagedJ website http://imagej.nih.gov/ij/

Click on Download.

home | news | docs | download | plugins | resources | list | links

Download

Platform Independent

To install Imaged 1.44 on a computer with Java
pre-installed, or to upgrade to the latest full
distribution (including macros, plugins and LUTs),
download ijl44.zip (3MB) and extract the Imagel
directory. Use the Help>Update ImageJ command to upgrade
to the latest pre-release version.

Mac OS5 X

Download ImageJ 1.44 (5.4MB) as a double-clickable Mac
0S X application. Includes Imagel64, which uses Java 1.6
in 64-bit mode on Intel Macs running 0S X 10.5 or later.
(Instructions)

Linux

Download ImageJ 1.44 bundled with 32-bit Java (46MB) or
with 64-bit Java (40MB). Both versions include Java
1.6.0_20 from Sun and the Imagel source code.
(Instructions)

Windows

Download ImageJ 1.44 bundled with 32-bit Java 1.6.0 20
(28MB), with 64-hit Java 1.6.0_20 (24MB; reguires 64-bit
Windows) or without Java (3MB). (Instructions)

lllustration 2: The Imaged download page. Select the version for
your system including the right java version, 32 or 64 bit.
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System Properties E]@
: System Restore _ Automatic Updates -_ Femate i
General | ComputerMame |  Hardware | Advanced

|
|
Sustem:

Microsoft Windows %P

Professional xE4 Edition

Wersion 2003

Service Pack 2
Registered to

MRI-NET

——

7E5ES-652-3009135-50067

Computer.
Intel(R] #ean(R) CPU
5160 @& 3.00GH=

2.99GHZ 8,00 GB of RAM ?

Figure 3: The system is 64bit and has
8GB of memory.

Look at the properties of My Computer in the windows explorer, to find out if your system is 64bit
and how much memory it has. Download the ImagelJ version for your system with the appropriate
java included (32 or 64bit). Run the setup and answer the questions. At the end ImagelJ will be
started for the first time.

Welcome to Image.] E|

i:() The program will now be auto-configured, You may be prompted ko input the locations of various files that can not be auto-detected. Please consult
the installation instructions For Further assistance.

Figure 4: The first time Imaged is started it auto-configures the thread and memory settings.

ImageJ Configuration El

i A configuration file was successfully created as:
. ‘l) Z;\Program Files\ImageJ2Imagel.chg
with the Following parameters:
Line 1- .
Line Z- jrelbinijavaw. exe

Line 3- -&rmx640m -cpij.jar ij. Image]

Please consult the installation instructions For further details,

Figure 5: The configuration is written into the file
Imaged.cfg.

Now the ImageJ-launcher window will be displayed.
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= Image.
File Edit Image Process Anakze Pluging Window Help

D=y
-

B olc|ol<|4l+|8Ala|o]2|@wls 7] 4]8] | |»]

*Faint* ar multi-point selections fright click to switch)

Figure 6: The Imaged launcher window.

Solution 1.2: Memory-Configuration

Look at the system properties how much memory your machine has, then enter 3 of it in the
memory options:

# ImageJ 808
File | Edit Image Process Anakze Plugins  Window Help|
il gl oz Kojlel~slss]a] | |»
Polyga Cut Ctrl+¥
e (O[3 Ctrl+C
Copy to System
Paste Ctrl+¥

Paste Control...

Clear

Clear Outside

Fill Ctrl+F

Draw Ctrl+D

Irnvert Ctrl+ Shift+1

Selection -

|options ~ Line Width, .,
Input/Output...
Fonts...
Profile Plot Options...
Arrow Toal...
Point Tool...
wand Toal...
Colors...
Appearance...

Conversions...
!ﬁﬁa@g?ﬁreads...
Froxy Settings...
Cornpiler...

DICOM...

Figure 7: Run Edit>Options>Memory & Threads...
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@ Memory (32.bit) T |

Maximum mermory: 2250 MB
Farallel threads for stacks: 2

_keep multiple undo buffers

& Fun garbage collector on status bar click

0K | | Cancel| Help

Figure 8: The memory and threads
settings. The machine has 3GB RAM
and two cores.

If for example your machine has 3GB memory, you should enter % * 3000MB = 2250MB.

The content of the file ImageJ.cfg in the ImageJ base folder is:

jre\bin\javaw.exe
-Xmx2250m —-cp ij.jar ij.Imaged

Solution 1.3: Update

@ ImageJ & @ ®
File Edit Image Frocess Analyze Plugins window -I—_ielpl_I

& | /f | PO | ||m5'99J wehsite...

Image| Mews...
Cocumentation...
" Installation...
Mailing List...

Imagel 1.45h / Java 1.6.0_20 (32-hit)

Dew, Resources...
Plugins...
Macros...

Macro Functions..,

[Update imagel...
Refresh Menus

About Plugins .

Figure 9: The Help>Update ImageJ menu.
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& Imagel Updater " & I

Upgrade To; wl.45h |

You are currently running w1.45h.

If wou click "OK", Image) will guit
and you will be running the upgraded
version after you restart Imagel.

Cancel

Figure 10: You can either choose the
current version, an older version or the
daily build.

Image) 1.45h

Figure 11: The about-dialog shows the version information.

Solution 1.4: ImageJ folders

I”/} jre I”J luts
I”/} macras [/f plugins

% ij.jar

[ Imaged
&y | Executable Jar File |l | Internet Shortout
= | 1510k | 1B
Imagel.cfg Imagel.exe
_FG File Image] Launcher
1 KB Broken Symmetry Software
[T README html unins000.dat
e Firefox Document DAT File
| IKE 53 KE
_'@ unins000, exe

I ‘i‘hj SetupfUninstall

Figure 12: The content of the Imaged base folder.
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& Mandelbrot.txt B ® I

File Edit Font | " Debug ,
/f Mandelbrot set diR4n Macra Ctri+R =
/| jerome mutterer ; Evaluate Line Ctrl+y J

Abort Macro
// This macro draws Install Macros Ctrl+| i in by

/{ making a selectio Function Finder...  Ctrl+Shift+F e macro,

/! which illustrates t— 1ass arguments
// from one macro & Evaluate JavaScript Ctrl+] Imacro is
/! benchmarked., Mandelbrat !

// Example results, all obtained with || 1.311 and java 1.3.1 jre :
/f Pentium 1I-350 Mhz 53.44 secs

[/ Pentium 11-500 Mhz 45,09 secs

/f Pentium V-1800 Mhz 11.53 secs

H acGA AG0 Mh R7 NS cerg |

fed ]

Figure 13: Running a macro from the macro-editor.

Figure 14: The result of running the
Mandelbrot-Macro.

b)
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File  Edit Image Process  Analeze | Plugins  Window Help
B clalol 4] +/x[Alafofrm e ] |-
Developer Menu il |

 Mew

Compile and Run...

a0

Analyze -

[Examples ~ Macros
Filters ~ Scripts
Graphics ~ |P Demo
Input-Output Image Inverter
LoCl Mandelbrot
LoG3D ~ Plasma2
Macros - Red And Blue
Frocess - [—
Segmentation

Stacks

Tools

Figure 15: The Mandelbrot command appears in the Plugins menu.

c) Instead of running the macro, the text file is opened in the macro-editor.

Solution 1.5: Opening images

a)

Figure 16: The image A4 dapi1 .tif.

b)
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# Open Folder B ® I

Open all 17 images in "arabidopsis" as a stack?

_IConvert to RGB
_lUse Virtual Stack

ves | | Mo | cancel |
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Figure 17: The open folder dialog.

& arabidopsis ®E®
1717 (Pot104Cycle00B3) 3524280 pixels; RGE; 6.4ME

rEC]

T —
Figure 18: The image-stack created from the
images in the Arabidopsis folder.

# Sequence Options B & I

MNurnber of images:
Starting image:
Increment:

Scale images:

File narme contains:
or enter pattern:
_IConvert to RGBE

W Sort names numerically

UlUse virtual stack

352 %280 %17 (6.4MB)

| oK | [cancel| [Help |

ST

Il

Figure 19: A dialog that allows
to import image-sequences.
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l\!ulll[‘L lieh RLC Lmeging

Figure 20: The image opened in ImagedJ by dragging the link
onto the launcher window.

d) The second time ImageJ adds -1 to the name to avoid confusion. For example opening the
Image A4 dapi 1.tif twice, results in one image with the title A4 dapi 1.tif and another one
with the title A4 dapi 1-1.tif.

e)

@ cafe.lsm (50%)
172 (Ch2-T1); 146,35:146.33 pm (1320:1320); 8-bit: 3.3MB

Chl

Figure 21: The image cafe.lsm displayed in composite-mode.
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@& Bio-Formats Import Options B ®
Stackviewing ————————————  Metadataviewing ———— Information
Wiew stack with: Hype_rs_;tack Display metadata 'Display metadata - Reads metadata that

may be contained within the file format and
displays it. You can save it as a text file or
Display ROIs copy it from the File and Edit menus specific
to the "Original Metadata" window.
Readahility depends upon the manner in
which metadata is formatted in the data
source. The metadata can also be displayed by
Open files individually Specify range for each series pressing "i" (Image > Show Info) when the
imported image is active.

Stack order: Display OME-XML metadata

Dataset organization —————————  Memory management -

Group files with similar names Use virtual stack

Swap dimensions Crop on import

Open all series

Concatenate series when compatible Split into separate windows
Color options ————— Split channels
Color rmode: Default Split focal planes

Autoscale Split timepoints

oK Cancel

Figure 22: The Bio-Formats Import Options.

v

Figure 23: The image FC green-40X sec.ics

g)
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# Miscellaneous Options K3

Divide by zero value: |Infinity

IUse pointer cursor
_|Hide "Process Stack? dialog

IRequire control key far shortocuts

_IMove izolated plugins to Misc, menu

W Run single instance listener

_|Debug mode

OK | Cancel| Help |

Figure 24: The misc-options dialog allows to activate the
single-instance-listener.

In windows, select open-with>Choose Program... from the context menu of a tif-file.
Browse to ImageJ.exe or select ImageJ Launcher if it appears already in the list. Select
“Always use the selected program...” and press ok.

Solution 1.6: The Image]J website
a)

26.11.7 Unsharp Mask...

M Unsharp Mask..

|
Radius (Sigma) 1.0 pixeis

Mask Weight (0.1-0.9) '0.60

L Preview

_Cancel J{_ OK )

Sharpens and enhances edges by subtracting a blurred version of the image (the
unsharp mask) from the original.

Unsharp masking subtracts a blurred copy of the image and rescales the image to
obtain the same contrast of large (low-frequency) structures as in the input image.
This is equivalent to adding a high-pass filtered image and thus sharpens the image.

Radius The standard deviation (o blur radius, cf. Gaussian Blur...T) of the Gaussian
blur that is subtracted. Increasing the Gaussian blur radius will increase contrast.

Mask Weight Determines the strength of filtering, whereby MaskWeight = 1 would
be an infinite weight of the high-pass filtered image that is added. Increasing the Mask
Weight value will provide additional edge enhancement.

Figure 25: The documentation of the command unsharp mask.
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Figure 26: The image before application of the unsharp mask
filter.

Figure 27: The image after application of the unsharp mask filter.

b) To the wiki of the workshop in which you are currently participating.
c) Colocalization_Analysis, JACOoP, ...
d) I find nine plugins that have to do with colocalization:

* Colocalization

* Colocalization Finder

* RG2B Colocalization

* JACoP (Just Another Colocalization Plugin)

* FRET and Colocalization Analyzer

* IntraCell
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* Find Colocalized Pixels in RGB Channels
* CDA (Confined Displacement Algorithm for Colocalization)

* Colocalization Colormap
e) It downloads an image cells.tif and counts the number of cells in the image.

File  Edit Font
Slice |Count [Total Area  |Awerage Size [AreaFraction [Mean [Mode |IntDen [

cells-1.4f 72 14022.241 194.851 12.7 255 255 49686.894

Figure 28: The number of cells in the summary table.

Figure 29: The outlines of the cells that have been counted by the macro.
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